<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Netflix&#039;s new epic fantasy series goes from low to high but lags behind &#039;the Witcher&#039; - Asap Land</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://asapland.com/wp-content/cache/min/1/946e7fdfc0ff535dc687f20c18295009.css" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" media="all" data-minify="1" />
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://asapland.com/xmlrpc.php" />
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v16.1.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<link rel="canonical" href="https://asapland.com/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Netflix&#039;s new epic fantasy series goes from low to high but lags behind &#039;the Witcher&#039; - Asap Land" />
	<meta property="og:description" content="&#8216;Shadow and Bone&#8217; is probably Netflix&#8217;s most ambitious premiere this April. Adaptation of the popular literary franchise of Leigh BardugoWe are facing a series in which it is evident that a very generous budget has been invested trying to achieve another great success for the platform. Now it remains to be seen how the public [&hellip;]" />
	<meta property="og:url" content="https://asapland.com/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/" />
	<meta property="og:site_name" content="Asap Land" />
	<meta property="article:published_time" content="2021-04-21T16:14:20+00:00" />
	<meta property="og:image" content="http://asapland.com/wp-content/uploads/2021/04/Netflix-seizes-Daggers-in-the-back-2-and-3-for.jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Maria Rivera">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="5 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO plugin. -->


<link rel="amphtml" href="https://asapland.com/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/amp/" /><meta name="generator" content="AMP for WP 1.0.76.12"/><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Asap Land &raquo; Feed" href="https://asapland.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Asap Land &raquo; Comments Feed" href="https://asapland.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Asap Land &raquo; Netflix&#8217;s new epic fantasy series goes from low to high but lags behind &#8216;the Witcher&#8217; Comments Feed" href="https://asapland.com/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>



<link rel='preload'   href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=10.3.3' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />

<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>



<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://asapland.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>

<script type='text/javascript' src='https://c0.wp.com/c/5.7.1/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>


<link rel="https://api.w.org/" href="https://asapland.com/wp-json/" /><link rel="alternate" type="application/json" href="https://asapland.com/wp-json/wp/v2/posts/74960" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://asapland.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://asapland.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.1" />
<link rel='shortlink' href='https://wp.me/pbaPlL-jv2' />
<style type='text/css'>img#wpstats{display:none}</style>
		<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"d83be0bd17","wpRestUrl":"https:\/\/asapland.com\/wp-json\/","permalinkStructure":"\/%postname%\/%post_id%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"on","origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/asapland.com\/wp-admin\/","wpRestNonce":"d83be0bd17","wpRestUrl":"https:\/\/asapland.com\/wp-json\/","permalinkStructure":"\/%postname%\/%post_id%\/"};
			</script>
			
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script data-no-minify="1" async src="https://asapland.com/wp-content/cache/busting/1/gtm-d50a7f43ce53cfb81ff2182712f55242.js"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-144838927-1');
</script>
<meta name="google-site-verification" content="XI4PbxYziSgQfs68Re_vYSAz1T67jTyqsx7NrRhzb20" />


<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://asapland.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://asapland.com/category/entertainment/",
                    "name": "Entertainment"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://asapland.com/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/",
                    "name": "Netflix&#8217;s new epic fantasy series goes from low to high but lags..."                                
                }
            }    
        ]
    }
</script>

<!-- Button style compiled by theme -->

<style>
    
</style>

	<style id="tdw-css-placeholder">.td-page-content p,
.td-post-content p,
.wpb_text_column p,
.td_block_text_with_title p,
.woocommerce #tab-description p,
.mce-content-body p,
.td-page-content li,
.td-post-content li,
.wpb_text_column li,
.td_block_text_with_title li,
.woocommerce #tab-description li,
.mce-content-body li {
  font-size: 17px;
  line-height: 26px;
}
.td_module_6 .entry-title {
  font-size: 16px;
}
</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script>
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head>

<body class="post-template-default single single-post postid-74960 single-format-standard td-standard-pack netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher global-block-template-1 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-cat-menu-container"><ul id="menu-cat-menu" class="td-mobile-main-menu"><li id="menu-item-373" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-373"><a href="https://asapland.com">Home</a></li>
<li id="menu-item-130" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130"><a href="https://asapland.com/category/business/">Business</a></li>
<li id="menu-item-132" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-132"><a href="https://asapland.com/category/technology/">Technology</a></li>
<li id="menu-item-131" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131"><a href="https://asapland.com/category/general-news/">General News</a></li>
<li id="menu-item-746" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-746"><a href="https://asapland.com/category/entertainment/">Entertainment</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                <div class="td-login-register-link">
	                
	                </div>
	                
	                

                </div>
            </div>

            
            
            
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://asapland.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 10
-->

<div class="td-header-wrap td-header-style-10 ">
    
    
    <div class="td-banner-wrap-full td-logo-wrap-full td-logo-mobile-loaded td-container-wrap ">
        <div class="td-header-sp-logo">
            		<a class="td-main-logo" href="https://asapland.com/">
			<img class="td-retina-data"  data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland.png" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%200'%3E%3C/svg%3E" alt="" width="300" data-lazy-src="https://asapland.com/wp-content/uploads/2019/05/asapland.png"/><noscript><img class="td-retina-data"  data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland.png" src="https://asapland.com/wp-content/uploads/2019/05/asapland.png" alt="" width="300"/></noscript>
			<span class="td-visual-hidden">Asap Land</span>
		</a>
	        </div>
    </div>

	<div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient ">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-header" href="https://asapland.com/">
			<img class="td-retina-data" data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland_small.jpg" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://asapland.com/wp-content/uploads/2019/05/asapland_small.jpg"/><noscript><img class="td-retina-data" data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland_small.jpg" src="https://asapland.com/wp-content/uploads/2019/05/asapland_small.jpg" alt=""/></noscript>
		</a>
			<a class="td-header-logo td-sticky-header" href="https://asapland.com/">
			<img class="td-retina-data" data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland.png" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://asapland.com/wp-content/uploads/2019/05/asapland.png"/><noscript><img class="td-retina-data" data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland.png" src="https://asapland.com/wp-content/uploads/2019/05/asapland.png" alt=""/></noscript>
		</a>
	    </div>
    <div class="menu-cat-menu-container"><ul id="menu-cat-menu-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-373"><a href="https://asapland.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-130"><a href="https://asapland.com/category/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-132"><a href="https://asapland.com/category/technology/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-131"><a href="https://asapland.com/category/general-news/">General News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-746"><a href="https://asapland.com/category/entertainment/">Entertainment</a></li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://asapland.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
			</div>
		</div>
	</div>

            <div class="td-banner-wrap-full td-banner-bg td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header tdi_1_4f4 td_block_template_1 ">

<style>
/* custom css */
.tdi_1_4f4.td-a-rec{
					text-align: center;
				}.tdi_1_4f4 .td-element-style{
					z-index: -1;
				}.tdi_1_4f4.td-a-rec-img{
				    text-align: left;
				}.tdi_1_4f4.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1_4f4.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-2968280150811945" data-ad-slot="8351339600"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2968280150811945" data-ad-slot="8351339600"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2968280150811945" data-ad-slot="8351339600"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-2968280150811945" data-ad-slot="8351339600"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 


</div>                </div>
            </div>
        </div>
    
</div>
            </div>

            
    <div class="td-main-content-wrap td-container-wrap">

        <div class="td-container td-post-template-default ">
            <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://asapland.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Entertainment" class="entry-crumb" href="https://asapland.com/category/entertainment/">Entertainment</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Netflix&#8217;s new epic fantasy series goes from low to high but lags...</span></div></div>

            <div class="td-pb-row">
                                        <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-74960" class="post-74960 post type-post status-publish format-standard category-entertainment" itemscope itemtype="https://schema.org/Article"47>
        <div class="td-post-header">

            <!-- category --><ul class="td-category"><li class="entry-category"><a  href="https://asapland.com/category/entertainment/">Entertainment</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Netflix&#8217;s new epic fantasy series goes from low to high but lags behind &#8216;the Witcher&#8217;</h1>
                

                <div class="td-module-meta-info">
                    <!-- author --><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://asapland.com/author/maria/">Maria Rivera</a><div class="td-author-line"> - </div> </div>                    <!-- date --><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-21T12:14:20-04:00" >April 21, 2021</time></span>                    <!-- comments -->                    <!-- views -->                </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-padding td-post-sharing-style2 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fasapland.com%2Fnetflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher%2F74960%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Netflix%E2%80%99s+new+epic+fantasy+series+goes+from+low+to+high+but+lags+behind+%E2%80%98the+Witcher%E2%80%99&url=https%3A%2F%2Fasapland.com%2Fnetflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher%2F74960%2F&via=Asap+Land">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://asapland.com/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/&amp;media=&description=Netflix%E2%80%99s+new+epic+fantasy+series+goes+from+low+to+high+but+lags+behind+%E2%80%98the+Witcher%E2%80%99">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Netflix%E2%80%99s+new+epic+fantasy+series+goes+from+low+to+high+but+lags+behind+%E2%80%98the+Witcher%E2%80%99 %0A%0A https://asapland.com/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://asapland.com/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/&title=Netflix%E2%80%99s+new+epic+fantasy+series+goes+from+low+to+high+but+lags+behind+%E2%80%98the+Witcher%E2%80%99">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>
        <div class="td-post-content tagdiv-type">
            <!-- image -->
            <!-- content --><div>
<p>&#8216;Shadow and Bone&#8217; is probably Netflix&#8217;s most ambitious premiere this April.  Adaptation of the popular literary franchise of <strong>Leigh Bardugo</strong>We are facing a series in which it is evident that a very generous budget has been invested trying to achieve another great success for the platform.  Now it remains to be seen how the public reacts to this first installment of the Grishaverso when it opens this coming Friday, April 23.</p>
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="d67ab1c4da760787c45a4fee4587e952" data-index="3" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- asap link -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2968280150811945"
     data-ad-slot="3154853240"
     data-ad-format="link"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></center><center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- asas square -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2968280150811945"
     data-ad-slot="9111911020"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<p><!-- BREAK 1 --></p>
<p>For my part, I have already been able to see the first four episodes of the eight that make up the debut of &#8216;Shadow and bone&#8217; and I have to confess that it has not exactly driven me crazy from the start, although it is true that it goes from less to more.  Efforts are noted in <strong>create your own wide universe</strong> with a mythology that serves to awaken the curiosity of the viewer and to expand this universe in such a way that there are enough claims not to throw in the towel despite its limitations.</p>
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="d67ab1c4da760787c45a4fee4587e952" data-index="1" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- asas square -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2968280150811945"
     data-ad-slot="9111911020"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<p><!-- BREAK 2 --> </p>
<h2>Lights and shadows</h2>
<p>The great protagonist of Alina Starkov -the last name I do not think is a coincidence, because in aspects such as the costumes the series refers you to certain Soviet elements, especially imperial Russia-, a young woman whose life changes when it is discovered that she has powers. <strong>The first chapter revolves exclusively around that idea</strong>, posing how her previous relationships are so that everything changes to save the person closest to her from certain death.</p>
<p><!-- BREAK 3 --></p>
<div class="article-asset article-asset-normal article-asset-center">
<div class="desvio-container">
<div class="desvio">
<div class="desvio-figure js-desvio-figure">
<p>     <img alt="The best Netflix movies of 2021 (for now)" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/Netflix-seizes-Daggers-in-the-back-2-and-3-for.jpeg?w=696"/><noscript><img alt="The best Netflix movies of 2021 (for now)" src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/Netflix-seizes-Daggers-in-the-back-2-and-3-for.jpeg?w=696" data-recalc-dims="1"/></noscript>
   </div>
</p></div>
</p></div>
</div>
<p>On paper it is not a bad start, but at the moment of truth it begins to show some elements of Netflix fiction that are a bit annoying.  The main one that they forget that the first episode has to serve to hook the viewer and feel the need to continue the journey, both physical and emotional, that its protagonists undertake.  Instead, <strong>here it feels a bit at half throttle, to go with the foot on the brake so that everything can give more of itself.</strong></p>
<p><!-- BREAK 4 --></p>
<div class="article-asset-image article-asset-large">
<div class="asset-content">
           <img class="sf-lazy "  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Bone Shadow Image" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/Netflixs-new-epic-fantasy-series-goes-from-low-to-high.jpeg?w=696"/><noscript><img class="sf-lazy "  src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/Netflixs-new-epic-fantasy-series-goes-from-low-to-high.jpeg?w=696" alt="Bone Shadow Image" data-recalc-dims="1"/></noscript><noscript><img alt="Bone Shadow Image" class="" src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/Netflixs-new-epic-fantasy-series-goes-from-low-to-high.jpeg?w=696" data-recalc-dims="1"/></noscript></p></div>
</div>
<p>It is true that this allows <strong>Eric Heisserer,</strong> creator of the series and scriptwriter of the first two episodes, to focus more on the particularities of this universe, introducing different concepts and fronts.  There it is revealed as a success the fact that &#8216;Shadow and bone&#8217; adapts at the same time two different sagas but connected to each other, since it brings greater dynamism to the series, not to say that the subplot from the bilogy &#8216;Six de Cuervos&#8217; that Heisserer sold as a cross between &#8216;Game of Thrones&#8217; and&#8217; Ocean&#8217;s 11 &#8216;is far more exhilarating than the main one.</p>
<p><!-- BREAK 5 --></p>
<div class="article-asset article-asset-normal article-asset-center">
<div class="desvio-container">
<div class="desvio">
<div class="desvio-figure js-desvio-figure">
<p>     <img alt="The 11 best series of 2021 ... so far" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/1617908446_686_a-stimulating-series-of-palatial-intrigues-on-Antena-3-that.jpeg?w=696"/><noscript><img alt="The 11 best series of 2021 ... so far" src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/1617908446_686_a-stimulating-series-of-palatial-intrigues-on-Antena-3-that.jpeg?w=696" data-recalc-dims="1"/></noscript>
   </div>
</p></div>
</p></div>
</div>
<p>Not that there is anything particularly exciting about it, but there &#8216;Shadow and bone&#8217; knows better how to play with the expectations of the public, first by knowing what exactly they want and then by all the added difficulties that arise along the way, without forget the need to connect it in some way with the central plot.  The challenge was very big and I may not have fallen in love, but I did fall in love with Heisserer <strong>he gradually makes the characters grow, working much better here than with Alina.</strong></p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://asapland.com/brutal-wild-and-self-conscious-entertainment/74040/" target="_self" class="u748c642d0b3760f0ef86612cd461a79e"><!-- INLINE RELATED POSTS 1/1 //--><style> .u748c642d0b3760f0ef86612cd461a79e { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:#eaeaea; border:0!important; border-left:4px solid #34495E!important; box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -moz-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -o-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -webkit-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); text-decoration:none; } .u748c642d0b3760f0ef86612cd461a79e:active, .u748c642d0b3760f0ef86612cd461a79e:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .u748c642d0b3760f0ef86612cd461a79e { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .u748c642d0b3760f0ef86612cd461a79e .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .u748c642d0b3760f0ef86612cd461a79e .postTitle { color:#000000; text-decoration: underline!important; font-size: 16px; } .u748c642d0b3760f0ef86612cd461a79e:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">READ:</span>&nbsp; <span class="postTitle">brutal, wild and self-conscious entertainment</span></div></a></div><!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="d67ab1c4da760787c45a4fee4587e952" data-index="1" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- asas square -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2968280150811945"
     data-ad-slot="9111911020"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<p><!-- BREAK 6 --></p>
<h2>Half gas</h2>
<div class="article-asset-image article-asset-large">
<div class="asset-content">
           <img class="sf-lazy "  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Shadow Bone Scene" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/1619021659_975_Netflixs-new-epic-fantasy-series-goes-from-low-to-high.jpeg?w=696"/><noscript><img class="sf-lazy "  src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/1619021659_975_Netflixs-new-epic-fantasy-series-goes-from-low-to-high.jpeg?w=696" alt="Shadow Bone Scene" data-recalc-dims="1"/></noscript><noscript><img alt="Shadow Bone Scene" class="" src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/1619021659_975_Netflixs-new-epic-fantasy-series-goes-from-low-to-high.jpeg?w=696" data-recalc-dims="1"/></noscript></p></div>
</div>
<p>There it gives the feeling that &#8216;Shadow and bone&#8217; <strong>wants to be special but without giving convincing arguments to convey that idea to the viewer.</strong> That may be different with those who already love the original material beforehand, but here you have to know as much to reconquer those who already know this world as to offer a seductive gateway to the rest of the public.  In the first I am afraid I cannot help you, but in the second it triumphs visually, remaining a bit of no-man&#8217;s-land in the narrative.</p>
<p><!-- BREAK 7 --></p>
<p>It is clear that there are going to be many who want to compare &#8216;Shadow and Bone&#8217; with &#8216;Game of Thrones&#8217; because of the enormous hook that the HBO series continues to have or with &#8216;The Witcher&#8217; for being the great Netflix fantasy series, but At the moment of truth, everything feels smaller within the ideas and themes that it handles, more along the lines of proposals such as &#8216;Damn&#8217; but with a budget or at least a somewhat higher ambition.</p>
<p><!-- BREAK 8 --></p>
<div class="article-asset-image article-asset-large">
<div class="asset-content">
           <img class="sf-lazy "  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Bone Shadow Scene" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/1619021659_396_Netflixs-new-epic-fantasy-series-goes-from-low-to-high.jpeg?w=696"/><noscript><img class="sf-lazy "  src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/1619021659_396_Netflixs-new-epic-fantasy-series-goes-from-low-to-high.jpeg?w=696" alt="Bone Shadow Scene" data-recalc-dims="1"/></noscript><noscript><img alt="Bone Shadow Scene" class="" src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/1619021659_396_Netflixs-new-epic-fantasy-series-goes-from-low-to-high.jpeg?w=696" data-recalc-dims="1"/></noscript></p></div>
</div>
<p>That is where <strong>frictions arise</strong> between an irreproachable visual and technical finish, although it is fair to say that it would be good for him to unleash himself more often since it is only then that he manages to reach a really satisfactory level of intensity, and a somewhat slow story progression, and in which he is also It smells too much what is to come in relation to the protagonist.  One thing is a logical progression and another that feels somewhat predictable and discourages you from continuing to watch the series.</p>
<p><!-- BREAK 9 --><!-- PIVOT START --></p>
<div class="pivot-ecommerce-container">
<div class="pivot-ecommerce">
<div class="pivot-ecommerce-figure">
   <img alt="Shadow and Bone: Grishaverse, Leftover and Bone trilogy, 1" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/Netflixs-new-epic-fantasy-series-goes-from-low-to-high.jpg?w=696"/><noscript><img alt="Shadow and Bone: Grishaverse, Leftover and Bone trilogy, 1" src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/Netflixs-new-epic-fantasy-series-goes-from-low-to-high.jpg?w=696" data-recalc-dims="1"/></noscript></div>
<div class="pivot-ecommerce-summary">
<p class="pivot-ecommerce-desc">Shadow and Bone: Grishaverse, Leftover and Bone trilogy, 1</p>
</p></div>
</p></div>
</div>
<p><!-- PIVOT END --></p>
<p><strong>Not that in the case of &#8216;Shadow and Bone&#8217; it is especially annoying</strong>, but it does limit the series to the point that it is more difficult to let go and want to explore this world.  It is a bittersweet sensation that at least is not so accentuated as the episodes progress, but in no case does it disappear, detracting from the dramatic packaging of everything that happens to its protagonist.  The cast does what they can to get us involved with their characters, but it is fair to point out that none of them ever shine.</p>
<p><!-- BREAK 10 --></p>
<h2>In short</h2>
<div class="article-asset-image article-asset-large">
<div class="asset-content">
           <img class="sf-lazy "  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Shadow Bone Image" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/i.blogs.es/c79101/sombra-hueso-imagen/450_1000.jpeg?w=696&#038;ssl=1"/><noscript><img class="sf-lazy "  src="https://i0.wp.com/i.blogs.es/c79101/sombra-hueso-imagen/450_1000.jpeg?w=696&#038;ssl=1" alt="Shadow Bone Image" data-recalc-dims="1"/></noscript><noscript><img alt="Shadow Bone Image" class="" src="https://i0.wp.com/i.blogs.es/c79101/sombra-hueso-imagen/450_1000.jpeg?w=696&#038;ssl=1" data-recalc-dims="1"/></noscript></p></div>
</div>
<p>&#8216;Shadow and bone&#8217; is a series with stimulating ideas and quite attractive from a purely visual point of view, but when it comes to the story it tells, it does not quite find the keys necessary to make it feel as important as it seems to be.  Despite this, <strong>it looks with some pleasure</strong> and knows how to give a necessary sense of unity despite having several open fronts.</p>
<p><!-- BREAK 11 -->
 </div>

<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="d67ab1c4da760787c45a4fee4587e952" data-index="2" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- asap link -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2968280150811945"
     data-ad-slot="3154853240"
     data-ad-format="link"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div>        </div>

        <footer>
            <!-- post pagination -->            <!-- review -->
            <div class="td-post-source-tags">
                <!-- source via -->                <!-- tags -->            </div>

            <div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-padding td-post-sharing-style2 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fasapland.com%2Fnetflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher%2F74960%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Netflix%E2%80%99s+new+epic+fantasy+series+goes+from+low+to+high+but+lags+behind+%E2%80%98the+Witcher%E2%80%99&url=https%3A%2F%2Fasapland.com%2Fnetflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher%2F74960%2F&via=Asap+Land">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://asapland.com/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/&amp;media=&description=Netflix%E2%80%99s+new+epic+fantasy+series+goes+from+low+to+high+but+lags+behind+%E2%80%98the+Witcher%E2%80%99">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Netflix%E2%80%99s+new+epic+fantasy+series+goes+from+low+to+high+but+lags+behind+%E2%80%98the+Witcher%E2%80%99 %0A%0A https://asapland.com/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://asapland.com/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/&title=Netflix%E2%80%99s+new+epic+fantasy+series+goes+from+low+to+high+but+lags+behind+%E2%80%98the+Witcher%E2%80%99">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <!-- next prev --><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://asapland.com/psychonauts-2-is-now-playable-internally-and-its-launch-is-closer/74800/">Psychonauts 2 is now playable internally and its launch is closer</a></div></div><div class="td-next-prev-separator"></div></div>            <!-- author box --><div class="author-box-wrap"><a href="https://asapland.com/author/maria/"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2096%2096'%3E%3C/svg%3E" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default" data-lazy-src="https://secure.gravatar.com/avatar/2ab502300203a26505fd95f7eb9d27c0?s=96&#038;d=mm&#038;r=g" /><noscript><img src="https://secure.gravatar.com/avatar/2ab502300203a26505fd95f7eb9d27c0?s=96&#038;d=mm&#038;r=g" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default" /></noscript></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://asapland.com/author/maria/">Maria Rivera</a></span></div><div class="td-author-description">Maria is the youngest team member of Asap Land. She joined as an intern as she was having a diploma in journalism. But, now as she gained experience, she is working as full-time editor and contributor on Asap Land. She loves to write news bulletins from the business world as she is quite fascinated with business.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div>            <!-- meta --><span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Maria Rivera"></span><meta itemprop="datePublished" content="2021-04-21T12:14:20-04:00"><meta itemprop="dateModified" content="2021-04-21T12:14:20-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://asapland.com/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://asapland.com/wp-content/uploads/2019/05/asapland.png"></span><meta itemprop="name" content="Asap Land"></span><meta itemprop="headline " content="Netflix&#039;s new epic fantasy series goes from low to high but lags behind &#039;the Witcher&#039;"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://asapland.com/wp-content/themes/Newspaper/images/no-thumb/td_meta_replacement.png"><meta itemprop="width" content="1068"><meta itemprop="height" content="580"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts tdi_3_505 td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_3_505" ><script>var block_tdi_3_505 = new tdBlock();
block_tdi_3_505.id = "tdi_3_505";
block_tdi_3_505.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_3_505","td_column_number":3,"live_filter_cur_post_id":74960,"live_filter_cur_post_author":"4","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_3_505","tdc_css_class_style":"tdi_3_505_rand_style"}';
block_tdi_3_505.td_column_number = "3";
block_tdi_3_505.block_type = "td_block_related_posts";
block_tdi_3_505.post_count = "3";
block_tdi_3_505.found_posts = "2365";
block_tdi_3_505.header_color = "";
block_tdi_3_505.ajax_pagination_infinite_stop = "";
block_tdi_3_505.max_num_pages = "789";
tdBlocksArray.push(block_tdi_3_505);
</script><h4 class="td-related-title td-block-title"><a id="tdi_4_ff0" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_3_505" href="#">RELATED ARTICLES</a><a id="tdi_5_806" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_3_505" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_3_505 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://asapland.com/psychonauts-2-is-now-playable-internally-and-its-launch-is-closer/74800/" rel="bookmark" class="td-image-wrap " title="Psychonauts 2 is now playable internally and its launch is closer" ><img width="218" height="150" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E"  data-lazy-srcset="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?resize=218%2C150&ssl=1 218w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?resize=100%2C70&ssl=1 100w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?zoom=2&resize=218%2C150 436w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?zoom=3&resize=218%2C150 654w" data-lazy-sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Psychonauts 2 is now playable internally and its launch is closer" data-lazy-src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?resize=218%2C150&ssl=1" /><noscript><img width="218" height="150" class="entry-thumb" src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?resize=218%2C150&ssl=1"  srcset="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?resize=218%2C150&ssl=1 218w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?resize=100%2C70&ssl=1 100w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?zoom=2&resize=218%2C150 436w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?zoom=3&resize=218%2C150 654w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Psychonauts 2 is now playable internally and its launch is closer" /></noscript></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://asapland.com/psychonauts-2-is-now-playable-internally-and-its-launch-is-closer/74800/" rel="bookmark" title="Psychonauts 2 is now playable internally and its launch is closer">Psychonauts 2 is now playable internally and its launch is closer</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://asapland.com/yoko-taro-is-working-on-a-completely-new-game-and-yes-it-will-be-strange/74793/" rel="bookmark" class="td-image-wrap " title="Yoko Taro is working on a completely new game and yes, it will be strange" ><img width="218" height="150" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E"  data-lazy-srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?zoom=2&resize=218%2C150 436w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?zoom=3&resize=218%2C150 654w" data-lazy-sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Yoko Taro is working on a completely new game and yes, it will be strange" data-lazy-src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?resize=218%2C150&ssl=1" /><noscript><img width="218" height="150" class="entry-thumb" src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?resize=218%2C150&ssl=1"  srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?zoom=2&resize=218%2C150 436w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?zoom=3&resize=218%2C150 654w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Yoko Taro is working on a completely new game and yes, it will be strange" /></noscript></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://asapland.com/yoko-taro-is-working-on-a-completely-new-game-and-yes-it-will-be-strange/74793/" rel="bookmark" title="Yoko Taro is working on a completely new game and yes, it will be strange">Yoko Taro is working on a completely new game and yes, it will be strange</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://asapland.com/red-dead-redemption-2-a-great-glitch-appears-on-the-horse/74786/" rel="bookmark" class="td-image-wrap " title="Red Dead Redemption 2: a great glitch appears on the horse" ><img width="218" height="150" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E"  data-lazy-srcset="https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?resize=218%2C150&ssl=1 218w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?resize=100%2C70&ssl=1 100w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?zoom=2&resize=218%2C150 436w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?zoom=3&resize=218%2C150 654w" data-lazy-sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Red Dead Redemption 2: a great glitch appears on the horse" data-lazy-src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?resize=218%2C150&ssl=1" /><noscript><img width="218" height="150" class="entry-thumb" src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?resize=218%2C150&ssl=1"  srcset="https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?resize=218%2C150&ssl=1 218w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?resize=100%2C70&ssl=1 100w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?zoom=2&resize=218%2C150 436w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?zoom=3&resize=218%2C150 654w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Red Dead Redemption 2: a great glitch appears on the horse" /></noscript></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://asapland.com/red-dead-redemption-2-a-great-glitch-appears-on-the-horse/74786/" rel="bookmark" title="Red Dead Redemption 2: a great glitch appears on the horse">Red Dead Redemption 2: a great glitch appears on the horse</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_3_505" data-td_block_id="tdi_3_505"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_3_505" data-td_block_id="tdi_3_505"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
        <div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://asapland.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
				<div class="comment-form-input-wrap td-form-comment">
					<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
					<div class="td-warning-comment">Please enter your comment!</div>
				</div>
		        <div class="comment-form-input-wrap td-form-author">
			            <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-author">Please enter your name here</div>
			         </div>
<div class="comment-form-input-wrap td-form-email">
			            <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-email-error">You have entered an incorrect email address!</div>
			            <div class="td-warning-email">Please enter your email address here</div>
			         </div>
<div class="comment-form-input-wrap td-form-url">
			            <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
                     </div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='74960' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="44c2f980fb" /></p><input type="hidden" id="ak_js" name="ak_js" value="60"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	    </div> <!-- /.content -->
                                </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside id="search-2" class="td_block_template_1 widget search-2 widget_search"><form method="get" class="td-search-form-widget" action="https://asapland.com/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside id="text-2" class="td_block_template_1 widget text-2 widget_text"><h4 class="block-title"><span>Get in Touch!</span></h4>			<div class="textwidget"><p>To get in touch with <strong>Asap Land</strong>, please write to <a href="/cdn-cgi/l/email-protection#f39f9a8092978681929d879880d3b3d3949e929a9fdd909c9ef9">lisadurantks @ gmail.com<br />
</a>. We will try our best to respond quickly. However, expect around 24 hours to get a response.</p>
</div>
		</aside><div class="td_block_wrap td_block_7 td_block_widget tdi_6_081 td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="tdi_6_081" ><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_6_081 = new tdBlock();
block_tdi_6_081.id = "tdi_6_081";
block_tdi_6_081.atts = '{"custom_title":"Related News","custom_url":"","block_template_id":"","header_color":"#","header_text_color":"#","accent_text_color":"#","m6_tl":"","limit":"8","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_6_081","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"tdi_6_081","tdc_css_class_style":"tdi_6_081_rand_style"}';
block_tdi_6_081.td_column_number = "1";
block_tdi_6_081.block_type = "td_block_7";
block_tdi_6_081.post_count = "8";
block_tdi_6_081.found_posts = "3186";
block_tdi_6_081.header_color = "#";
block_tdi_6_081.ajax_pagination_infinite_stop = "";
block_tdi_6_081.max_num_pages = "399";
tdBlocksArray.push(block_tdi_6_081);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">Related News</span></h4></div><div id=tdi_6_081 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/" rel="bookmark" class="td-image-wrap " title="Netflix&#8217;s new epic fantasy series goes from low to high but lags behind &#8216;the Witcher&#8217;" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  alt="" data-lazy-src="https://asapland.com/wp-content/plugins/td-standard-pack/Newspaper/assets/images/no-thumb/td_100x70.png" /><noscript><img width="100" height="70" class="entry-thumb" src="https://asapland.com/wp-content/plugins/td-standard-pack/Newspaper/assets/images/no-thumb/td_100x70.png"  alt="" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/netflixs-new-epic-fantasy-series-goes-from-low-to-high-but-lags-behind-the-witcher/74960/" rel="bookmark" title="Netflix&#8217;s new epic fantasy series goes from low to high but lags behind &#8216;the Witcher&#8217;">Netflix&#8217;s new epic fantasy series goes from low to high but...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-21T12:14:20-04:00" >April 21, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/psychonauts-2-is-now-playable-internally-and-its-launch-is-closer/74800/" rel="bookmark" class="td-image-wrap " title="Psychonauts 2 is now playable internally and its launch is closer" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  data-lazy-srcset="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?resize=218%2C150&ssl=1 218w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?resize=100%2C70&ssl=1 100w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?zoom=3&resize=100%2C70 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Psychonauts 2 is now playable internally and its launch is closer" data-lazy-src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?resize=100%2C70&ssl=1" /><noscript><img width="100" height="70" class="entry-thumb" src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?resize=100%2C70&ssl=1"  srcset="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?resize=218%2C150&ssl=1 218w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?resize=100%2C70&ssl=1 100w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/psychonauts-2-is-playable-internally-and-coming-later-this-y_3hnj.1200.jpg?zoom=3&resize=100%2C70 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Psychonauts 2 is now playable internally and its launch is closer" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/psychonauts-2-is-now-playable-internally-and-its-launch-is-closer/74800/" rel="bookmark" title="Psychonauts 2 is now playable internally and its launch is closer">Psychonauts 2 is now playable internally and its launch is closer</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-21T12:00:40-04:00" >April 21, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/yoko-taro-is-working-on-a-completely-new-game-and-yes-it-will-be-strange/74793/" rel="bookmark" class="td-image-wrap " title="Yoko Taro is working on a completely new game and yes, it will be strange" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  data-lazy-srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?zoom=3&resize=100%2C70 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Yoko Taro is working on a completely new game and yes, it will be strange" data-lazy-src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?resize=100%2C70&ssl=1" /><noscript><img width="100" height="70" class="entry-thumb" src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?resize=100%2C70&ssl=1"  srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/yoko-taro-is-working-on-a-completely-new-game-and-yes-itll-b_cckd.1200.jpg?zoom=3&resize=100%2C70 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Yoko Taro is working on a completely new game and yes, it will be strange" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/yoko-taro-is-working-on-a-completely-new-game-and-yes-it-will-be-strange/74793/" rel="bookmark" title="Yoko Taro is working on a completely new game and yes, it will be strange">Yoko Taro is working on a completely new game and yes,...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-21T11:45:43-04:00" >April 21, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/red-dead-redemption-2-a-great-glitch-appears-on-the-horse/74786/" rel="bookmark" class="td-image-wrap " title="Red Dead Redemption 2: a great glitch appears on the horse" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  data-lazy-srcset="https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?resize=218%2C150&ssl=1 218w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?resize=100%2C70&ssl=1 100w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?zoom=3&resize=100%2C70 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Red Dead Redemption 2: a great glitch appears on the horse" data-lazy-src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?resize=100%2C70&ssl=1" /><noscript><img width="100" height="70" class="entry-thumb" src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?resize=100%2C70&ssl=1"  srcset="https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?resize=218%2C150&ssl=1 218w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?resize=100%2C70&ssl=1 100w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/04/re_yan2.1200.jpg?zoom=3&resize=100%2C70 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Red Dead Redemption 2: a great glitch appears on the horse" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/red-dead-redemption-2-a-great-glitch-appears-on-the-horse/74786/" rel="bookmark" title="Red Dead Redemption 2: a great glitch appears on the horse">Red Dead Redemption 2: a great glitch appears on the horse</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-21T11:30:33-04:00" >April 21, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/the-suicide-squad-james-gunn-reports-that-the-film-is-ready-for-release/74780/" rel="bookmark" class="td-image-wrap " title="The Suicide Squad: James Gunn reports that the film is ready for release" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  data-lazy-srcset="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/sui1_4myf.1200.jpg?resize=218%2C150&ssl=1 218w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/sui1_4myf.1200.jpg?resize=100%2C70&ssl=1 100w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/sui1_4myf.1200.jpg?zoom=3&resize=100%2C70 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px"  alt="" title="The Suicide Squad: James Gunn reports that the film is ready for release" data-lazy-src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/sui1_4myf.1200.jpg?resize=100%2C70&ssl=1" /><noscript><img width="100" height="70" class="entry-thumb" src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/sui1_4myf.1200.jpg?resize=100%2C70&ssl=1"  srcset="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/sui1_4myf.1200.jpg?resize=218%2C150&ssl=1 218w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/sui1_4myf.1200.jpg?resize=100%2C70&ssl=1 100w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/sui1_4myf.1200.jpg?zoom=3&resize=100%2C70 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="The Suicide Squad: James Gunn reports that the film is ready for release" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/the-suicide-squad-james-gunn-reports-that-the-film-is-ready-for-release/74780/" rel="bookmark" title="The Suicide Squad: James Gunn reports that the film is ready for release">The Suicide Squad: James Gunn reports that the film is ready...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-21T11:15:52-04:00" >April 21, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/you-cobra-kai-and-the-witcher-will-return-in-2021-netflix-wants-to-get-back-to-rhythm-with-its-most-powerful-series/74956/" rel="bookmark" class="td-image-wrap " title="&#8216;You&#8217;, &#8216;Cobra Kai&#8217; and &#8216;The Witcher&#8217; will return in 2021: Netflix wants to get back to rhythm with its most powerful series" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  data-lazy-srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/1619017898_840_560.jpeg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/1619017898_840_560.jpeg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/1619017898_840_560.jpeg?zoom=3&resize=100%2C70 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px"  alt="" title="&#8216;You&#8217;, &#8216;Cobra Kai&#8217; and &#8216;The Witcher&#8217; will return in 2021: Netflix wants to get back to rhythm with its most powerful series" data-lazy-src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/1619017898_840_560.jpeg?resize=100%2C70&ssl=1" /><noscript><img width="100" height="70" class="entry-thumb" src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/1619017898_840_560.jpeg?resize=100%2C70&ssl=1"  srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/1619017898_840_560.jpeg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/1619017898_840_560.jpeg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/1619017898_840_560.jpeg?zoom=3&resize=100%2C70 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="&#8216;You&#8217;, &#8216;Cobra Kai&#8217; and &#8216;The Witcher&#8217; will return in 2021: Netflix wants to get back to rhythm with its most powerful series" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/you-cobra-kai-and-the-witcher-will-return-in-2021-netflix-wants-to-get-back-to-rhythm-with-its-most-powerful-series/74956/" rel="bookmark" title="&#8216;You&#8217;, &#8216;Cobra Kai&#8217; and &#8216;The Witcher&#8217; will return in 2021: Netflix wants to get back to rhythm with its most powerful series">&#8216;You&#8217;, &#8216;Cobra Kai&#8217; and &#8216;The Witcher&#8217; will return in 2021: Netflix...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-21T11:11:38-04:00" >April 21, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/mad-max-furious-will-be-very-different-from-fury-road/74778/" rel="bookmark" class="td-image-wrap " title="Mad Max: Furious will be very different from Fury Road" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  data-lazy-srcset="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/mad-max-furiosa-will-be-structured-very-differently-than-fur_xkeu.1200.jpg?resize=218%2C150&ssl=1 218w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/mad-max-furiosa-will-be-structured-very-differently-than-fur_xkeu.1200.jpg?resize=100%2C70&ssl=1 100w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/mad-max-furiosa-will-be-structured-very-differently-than-fur_xkeu.1200.jpg?zoom=3&resize=100%2C70 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Mad Max: Furious will be very different from Fury Road" data-lazy-src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/mad-max-furiosa-will-be-structured-very-differently-than-fur_xkeu.1200.jpg?resize=100%2C70&ssl=1" /><noscript><img width="100" height="70" class="entry-thumb" src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/mad-max-furiosa-will-be-structured-very-differently-than-fur_xkeu.1200.jpg?resize=100%2C70&ssl=1"  srcset="https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/mad-max-furiosa-will-be-structured-very-differently-than-fur_xkeu.1200.jpg?resize=218%2C150&ssl=1 218w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/mad-max-furiosa-will-be-structured-very-differently-than-fur_xkeu.1200.jpg?resize=100%2C70&ssl=1 100w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/04/mad-max-furiosa-will-be-structured-very-differently-than-fur_xkeu.1200.jpg?zoom=3&resize=100%2C70 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Mad Max: Furious will be very different from Fury Road" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/mad-max-furious-will-be-very-different-from-fury-road/74778/" rel="bookmark" title="Mad Max: Furious will be very different from Fury Road">Mad Max: Furious will be very different from Fury Road</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-21T11:00:36-04:00" >April 21, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/cyberpunk-2077-some-mods-reactivate-inaccessible-missions-and-restore-the-original-appearance-of-v/74768/" rel="bookmark" class="td-image-wrap " title="Cyberpunk 2077: Some mods reactivate inaccessible missions and restore the original appearance of V" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  data-lazy-srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/cyberpunk-2077-mods-make-unused-quests-playable-and-v-appear_5mnv.1200.jpg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/cyberpunk-2077-mods-make-unused-quests-playable-and-v-appear_5mnv.1200.jpg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/cyberpunk-2077-mods-make-unused-quests-playable-and-v-appear_5mnv.1200.jpg?zoom=3&resize=100%2C70 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Cyberpunk 2077: Some mods reactivate inaccessible missions and restore the original appearance of V" data-lazy-src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/cyberpunk-2077-mods-make-unused-quests-playable-and-v-appear_5mnv.1200.jpg?resize=100%2C70&ssl=1" /><noscript><img width="100" height="70" class="entry-thumb" src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/cyberpunk-2077-mods-make-unused-quests-playable-and-v-appear_5mnv.1200.jpg?resize=100%2C70&ssl=1"  srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/cyberpunk-2077-mods-make-unused-quests-playable-and-v-appear_5mnv.1200.jpg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/cyberpunk-2077-mods-make-unused-quests-playable-and-v-appear_5mnv.1200.jpg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/04/cyberpunk-2077-mods-make-unused-quests-playable-and-v-appear_5mnv.1200.jpg?zoom=3&resize=100%2C70 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Cyberpunk 2077: Some mods reactivate inaccessible missions and restore the original appearance of V" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/cyberpunk-2077-some-mods-reactivate-inaccessible-missions-and-restore-the-original-appearance-of-v/74768/" rel="bookmark" title="Cyberpunk 2077: Some mods reactivate inaccessible missions and restore the original appearance of V">Cyberpunk 2077: Some mods reactivate inaccessible missions and restore the original...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-21T10:50:20-04:00" >April 21, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block --><aside id="top-posts-2" class="td_block_template_1 widget top-posts-2 widget_top-posts"><h4 class="block-title"><span>You May Like</span></h4><ul>				<li>
					<a href="https://asapland.com/the-simpsons-outperform-the-mandalorian-in-views-in-2020-despite-being-on-the-air-for-32-years/74620/" class="bump-view" data-bump-view="tp">The Simpsons outperform The Mandalorian in views in 2020 despite being on the air for 32 years</a>					</li>
								<li>
					<a href="https://asapland.com/how-to-use-whatsapp-on-two-mobiles-at-the-same-time-with-its-web-version/74870/" class="bump-view" data-bump-view="tp">How to use WhatsApp on two mobiles at the same time with its web version</a>					</li>
								<li>
					<a href="https://asapland.com/how-to-survive-an-atomic-bomb-and-why-it-is-better-not-to-run-after-the-explosion/74549/" class="bump-view" data-bump-view="tp">How to survive an atomic bomb (and why it is better not to run after the explosion)</a>					</li>
								<li>
					<a href="https://asapland.com/yayagram-or-how-to-use-a-raspberry-pi-to-help-the-elderly-communicate-with-their-grandchildren-via-telegram/74795/" class="bump-view" data-bump-view="tp">Yayagram, or how to use a Raspberry Pi to help the elderly communicate with their grandchildren via Telegram</a>					</li>
								<li>
					<a href="https://asapland.com/reckoning-season-2-netflix-release-date-details/41363/" class="bump-view" data-bump-view="tp">Reckoning Season 2 Netflix Release Date – Details</a>					</li>
								<li>
					<a href="https://asapland.com/tamilrockers/71024/" class="bump-view" data-bump-view="tp">TamilRockers: Download Hollywood Movies TamilRockers Tv Series Download</a>					</li>
								<li>
					<a href="https://asapland.com/hazbin-hotel-episode-2-release-date/69175/" class="bump-view" data-bump-view="tp">Hazbin Hotel Episode 2: Release Date, Characters, and Everything You Should Know</a>					</li>
								<li>
					<a href="https://asapland.com/tokyo-revengers-how-many-episodes-will-the-first-season-consist-of-the-details-on-the-anime/71605/" class="bump-view" data-bump-view="tp">Tokyo Revengers: how many episodes will the first season consist of?  The details on the anime</a>					</li>
								<li>
					<a href="https://asapland.com/vinland-saga-season-2-release-date/69114/" class="bump-view" data-bump-view="tp">&quot;Vinland Saga&quot; Season 2 - Release Date, Cast, Story Plot, and Everything We Know So Far</a>					</li>
								<li>
					<a href="https://asapland.com/have-you-heard-of-this-space-megablockbuster-it-has-been-abandoned-on-netflix-for-two-years-without-making-a-sound/74199/" class="bump-view" data-bump-view="tp">Have you heard of this space megablockbuster?  It has been abandoned on Netflix for two years without making a sound</a>					</li>
				</ul></aside>                            </div>
                        </div>
                                    </div> <!-- /.td-pb-row -->
        </div> <!-- /.td-container -->
    </div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->

	
	
            <div class="tdc-footer-wrap ">

                <!-- Footer -->
				<div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-9 ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                            </div>

            <div class="td-pb-span4">
                            </div>

            <div class="td-pb-span4">
                            </div>

        </div>
    </div>
</div>
                <!-- Sub Footer -->
				    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-page-menu-container"><ul id="menu-page-menu" class="td-subfooter-menu"><li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-129"><a href="https://asapland.com/home/">Home</a></li>
<li id="menu-item-378" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-378"><a href="https://asapland.com/about/">About</a></li>
<li id="menu-item-369" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-369"><a href="https://asapland.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-370" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-370"><a href="https://asapland.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-372" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-372"><a href="https://asapland.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-2242" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-2242"><a href="https://asapland.com/team/">Team</a></li>
<li id="menu-item-2241" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-2241"><a href="https://asapland.com/contact/">Contact</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Copyright © 2019 Asap Land.                </div>
            </div>
        </div>
    </div>
            </div><!--close td-footer-wrap-->
			
</div><!--close td-outer-wrap-->




    <!--

        Theme: Newspaper by tagDiv.com 2019
        Version: 10.3.3 (rara)
        Deploy mode: deploy
        
        uid: 60804f5f6950b
    -->

    



<script type='text/javascript' src='https://c0.wp.com/c/5.7.1/wp-includes/js/dist/i18n.min.js' id='wp-i18n-js'></script>






<script type='text/javascript' id='wp-api-fetch-js-after'>
wp.apiFetch.use( wp.apiFetch.createRootURLMiddleware( "https://asapland.com/wp-json/" ) );
wp.apiFetch.nonceMiddleware = wp.apiFetch.createNonceMiddleware( "d83be0bd17" );
wp.apiFetch.use( wp.apiFetch.nonceMiddleware );
wp.apiFetch.use( wp.apiFetch.mediaUploadMiddleware );
wp.apiFetch.nonceEndpoint = "https://asapland.com/wp-admin/admin-ajax.php?action=rest-nonce";
</script>









<!-- JS generated by theme -->



<script src='https://stats.wp.com/e-202116.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.6.1',blog:'165120369',post:'74960',tz:'-4',srv:'asapland.com'} ]);
	_stq.push([ 'clickTrackerInit', '165120369', '74960' ]);
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://asapland.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
<script>"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><script src="https://asapland.com/wp-content/cache/min/1/b2b2adb76dd1984cee4ae97157866029.js" data-minify="1" defer></script><noscript><link rel="stylesheet" href="https://asapland.com/wp-content/cache/min/1/946e7fdfc0ff535dc687f20c18295009.css" media="all" data-minify="1" /><link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=10.3.3' type='text/css' media='all' /></noscript></body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1619021663 -->