<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head><meta charset="UTF-8" /><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
<title>&quot;AMERICAN HORROR STORY&quot; 1984: THE THIRD EPISODE FINALE EXPLAINED!! - Asap Land</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap" /></noscript>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://asapland.com/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<link rel="canonical" href="https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="&quot;AMERICAN HORROR STORY&quot; 1984: THE THIRD EPISODE FINALE EXPLAINED!! - Asap Land" />
<meta property="og:description" content="American Horror Story: 1984 starts with several twists and turns, challenging the certainties of the fans. Thus, on the one hand there is a feeling of disorientation. On the other, there is a green light for the spectators&#8217; conjectures. Some of these have in fact tried to give an explanation to the final of the [&hellip;]" />
<meta property="og:url" content="https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/" />
<meta property="og:site_name" content="Asap Land" />
<meta property="article:published_time" content="2021-10-07T05:39:18+00:00" />
<meta property="article:modified_time" content="2021-10-07T05:39:46+00:00" />
<meta property="og:image" content="https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg" />
<meta property="og:image:width" content="650" />
<meta property="og:image:height" content="366" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Ryan Sanders" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://asapland.com/#organization","name":"ASAP Land News","url":"https://asapland.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://asapland.com/#logo","inLanguage":"en-US","url":"https://i2.wp.com/asapland.com/wp-content/uploads/2019/05/asapland_small.jpg?fit=100%2C30&ssl=1","contentUrl":"https://i2.wp.com/asapland.com/wp-content/uploads/2019/05/asapland_small.jpg?fit=100%2C30&ssl=1","width":100,"height":30,"caption":"ASAP Land News"},"image":{"@id":"https://asapland.com/#logo"}},{"@type":"WebSite","@id":"https://asapland.com/#website","url":"https://asapland.com/","name":"Asap Land","description":"Instant News Portal","publisher":{"@id":"https://asapland.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://asapland.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/#primaryimage","inLanguage":"en-US","url":"https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg","contentUrl":"https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg","width":650,"height":366,"caption":"American horror story 1984"},{"@type":"WebPage","@id":"https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/#webpage","url":"https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/","name":"\"AMERICAN HORROR STORY\" 1984: THE THIRD EPISODE FINALE EXPLAINED!! - Asap Land","isPartOf":{"@id":"https://asapland.com/#website"},"primaryImageOfPage":{"@id":"https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/#primaryimage"},"datePublished":"2021-10-07T05:39:18+00:00","dateModified":"2021-10-07T05:39:46+00:00","breadcrumb":{"@id":"https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/"]}]},{"@type":"BreadcrumbList","@id":"https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://asapland.com/"},{"@type":"ListItem","position":2,"name":"&#8220;AMERICAN HORROR STORY&#8221; 1984: THE THIRD EPISODE FINALE EXPLAINED!!"}]},{"@type":"Article","@id":"https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/#article","isPartOf":{"@id":"https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/#webpage"},"author":{"@id":"https://asapland.com/#/schema/person/410b775d128f6bb3ea1612640c39cfd7"},"headline":"&#8220;AMERICAN HORROR STORY&#8221; 1984: THE THIRD EPISODE FINALE EXPLAINED!!","datePublished":"2021-10-07T05:39:18+00:00","dateModified":"2021-10-07T05:39:46+00:00","mainEntityOfPage":{"@id":"https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/#webpage"},"wordCount":325,"commentCount":0,"publisher":{"@id":"https://asapland.com/#organization"},"image":{"@id":"https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/#primaryimage"},"thumbnailUrl":"https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg","keywords":["1984","American Horror Story","American horror story 1984","American Horror Story Season 9","American Horror Story Season 9 cast","American Horror Story Season 9 release date"],"articleSection":["Entertainment"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/#respond"]}]},{"@type":"Person","@id":"https://asapland.com/#/schema/person/410b775d128f6bb3ea1612640c39cfd7","name":"Ryan Sanders","image":{"@type":"ImageObject","@id":"https://asapland.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/c92a5441de286727f20af27ecc654217?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/c92a5441de286727f20af27ecc654217?s=96&d=mm&r=g","caption":"Ryan Sanders"},"description":"Ryan is the guy who has been there with Lisa since the inception of Asap Land. When Lisa shared the idea of starting a news website, he loved the idea and took a plunge into writing online news bulletins. He is now having quite good experience with sharing news in its original form.","url":"https://asapland.com/author/ryan/"}]}</script>

<link rel="amphtml" href="https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/amp/" /><meta name="generator" content="AMP for WP 1.0.77.25" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//adservice.google.com' />
<link rel='dns-prefetch' href='//partner.googleadservices.com' />
<link rel='dns-prefetch' href='//googleads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Asap Land &raquo; Feed" href="https://asapland.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Asap Land &raquo; Comments Feed" href="https://asapland.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Asap Land &raquo; &#8220;AMERICAN HORROR STORY&#8221; 1984: THE THIRD EPISODE FINALE EXPLAINED!! Comments Feed" href="https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://asapland.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://asapland.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8.1' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='contact-form-7-css' href='https://asapland.com/wp-content/cache/min/1/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=1632744145' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://asapland.com/wp-content/cache/min/1/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=1632744145' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='jetpack-top-posts-widget-css' href='https://asapland.com/wp-content/cache/min/1/wp-content/plugins/jetpack/modules/widgets/top-posts/style.css?ver=1632744145' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='td-theme-css' href='https://asapland.com/wp-content/cache/min/1/wp-content/themes/Newspaper/style.css?ver=1632744145' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link data-minify="1" rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://asapland.com/wp-content/cache/min/1/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=1632744145' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://asapland.com/wp-content/cache/min/1/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=1632744145' type='text/css' media='all' />
<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://asapland.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://asapland.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://asapland.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script>
<link rel="https://api.w.org/" href="https://asapland.com/wp-json/" /><link rel="alternate" type="application/json" href="https://asapland.com/wp-json/wp/v2/posts/3377" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://asapland.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://asapland.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.8.1" />
<link rel='shortlink' href='https://wp.me/pbaPlL-St' />
<style type='text/css'>img#wpstats{display:none}</style>
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script type="rocketlazyloadscript">
				window.tdwGlobal = {"adminUrl":"https:\/\/asapland.com\/wp-admin\/","wpRestNonce":"2c3bd4fa1f","wpRestUrl":"https:\/\/asapland.com\/wp-json\/","permalinkStructure":"\/%postname%\/%post_id%\/"};
			</script>
<script type="rocketlazyloadscript">
        window.tdaGlobal = {"adminUrl":"https:\/\/asapland.com\/wp-admin\/","wpRestNonce":"2c3bd4fa1f","wpRestUrl":"https:\/\/asapland.com\/wp-json\/","permalinkStructure":"\/%postname%\/%post_id%\/","postId":3377};
    </script>

<script type="rocketlazyloadscript">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</script>

<style>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</style>
<script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-2968280150811945" crossorigin="anonymous"></script>

<script type="rocketlazyloadscript" async src="https://www.googletagmanager.com/gtag/js?id=UA-144838927-1"></script>
<script type="rocketlazyloadscript">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-144838927-1');
</script>
<meta name="google-site-verification" content="XI4PbxYziSgQfs68Re_vYSAz1T67jTyqsx7NrRhzb20" />
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://asapland.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://asapland.com/category/entertainment/",
                    "name": "Entertainment"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/",
                    "name": "&#8220;AMERICAN HORROR STORY&#8221; 1984: THE THIRD EPISODE FINALE EXPLAINED!!"                                
                }
            }    
        ]
    }
</script>
<style type="text/css" id="wp-custom-css">
			#customad{
	min-height:250px;
	max-height: auto;
	width:100%;
}
.headerad{
	min-height:100px;
	max-height: auto;
}
.td-post-featured-image {
	height: auto;
	width: 100%;
}

.td-post-featured-image img {
	width: 100%!important;
}

.wp-caption-text, .wp-caption-dd {
	font-size: 11px!important;
	font-weight: 300!important;
}		</style>

<style>
    
</style>
<style id="tdw-css-placeholder">.td-page-content p,
.td-post-content p,
.wpb_text_column p,
.td_block_text_with_title p,
.woocommerce #tab-description p,
.mce-content-body p,
.td-page-content li,
.td-post-content li,
.wpb_text_column li,
.td_block_text_with_title li,
.woocommerce #tab-description li,
.mce-content-body li {
  font-size: 17px;
  line-height: 26px;
}
.td_module_6 .entry-title {
  font-size: 16px;
}
</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-3377 single-format-standard td-standard-pack american-horror-story-1984-the-third-episode-finale-explained global-block-template-1 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up  td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
</div>

<div class="td-mobile-close">
<a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-cat-menu-container"><ul id="menu-cat-menu" class="td-mobile-main-menu"><li id="menu-item-373" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-373"><a href="https://asapland.com">Home</a></li>
<li id="menu-item-130" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130"><a href="https://asapland.com/category/business/">Business</a></li>
<li id="menu-item-132" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-132"><a href="https://asapland.com/category/technology/">Technology</a></li>
<li id="menu-item-131" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131"><a href="https://asapland.com/category/general-news/">General News</a></li>
<li id="menu-item-746" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-746"><a href="https://asapland.com/category/entertainment/">Entertainment</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://asapland.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-10 ">
<div class="td-banner-wrap-full td-logo-wrap-full td-logo-mobile-loaded td-container-wrap ">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://asapland.com/">
<img class="td-retina-data" data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland.png" src="https://asapland.com/wp-content/uploads/2019/05/asapland.png" alt="" width="300" />
<span class="td-visual-hidden">Asap Land</span>
</a>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
 <div class="td-header-menu-wrap td-header-gradient ">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-header" href="https://asapland.com/">
<img class="td-retina-data" data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland.png" src="https://asapland.com/wp-content/uploads/2019/05/asapland.png" alt="" width="300" height="90" />
</a>
<a class="td-header-logo td-sticky-header" href="https://asapland.com/">
<img class="td-retina-data" data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland.png" src="https://asapland.com/wp-content/uploads/2019/05/asapland.png" alt="" width="300" height="90" />
</a>
</div>
<div class="menu-cat-menu-container"><ul id="menu-cat-menu-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-373"><a href="https://asapland.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-130"><a href="https://asapland.com/category/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-132"><a href="https://asapland.com/category/technology/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-131"><a href="https://asapland.com/category/general-news/">General News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-746"><a href="https://asapland.com/category/entertainment/">Entertainment</a></li>
</ul></div></div>
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://asapland.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-default ">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://asapland.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Entertainment" class="entry-crumb" href="https://asapland.com/category/entertainment/">Entertainment</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">&#8220;AMERICAN HORROR STORY&#8221; 1984: THE THIRD EPISODE FINALE EXPLAINED!!</span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class='code-block code-block-3' style='margin: 8px auto; text-align: center; display: block; clear: both; height:140px!important; width: 100%;'>

<ins class="adsbygoogle" style="display:inline-block;width:320px;height:100px" data-ad-client="ca-pub-2968280150811945" data-ad-slot="5194362291"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<article id="post-3377" class="post-3377 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment tag-1321 tag-american-horror-story tag-american-horror-story-1984 tag-american-horror-story-season-9 tag-american-horror-story-season-9-cast tag-american-horror-story-season-9-release-date" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header">
<ul class="td-category"><li class="entry-category"><a href="https://asapland.com/category/entertainment/">Entertainment</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">&#8220;AMERICAN HORROR STORY&#8221; 1984: THE THIRD EPISODE FINALE EXPLAINED!!</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://asapland.com/author/ryan/">Ryan Sanders</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-10-07T01:39:18-04:00">October 7, 2021</time></span>   </div>
</header>
</div>
<div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-padding td-post-sharing-style2 ">
<style>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</style>
<div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div>
<div class="td-social-but-text">Share</div>
</div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fasapland.com%2Famerican-horror-story-1984-the-third-episode-finale-explained%2F3377%2F" title="Facebook">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=%E2%80%9CAMERICAN+HORROR+STORY%E2%80%9D+1984%3A+THE+THIRD+EPISODE+FINALE+EXPLAINED%21%21&url=https%3A%2F%2Fasapland.com%2Famerican-horror-story-1984-the-third-episode-finale-explained%2F3377%2F&via=Asap+Land" title="Twitter">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/&amp;media=https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg&description=%E2%80%9CAMERICAN+HORROR+STORY%E2%80%9D+1984%3A+THE+THIRD+EPISODE+FINALE+EXPLAINED%21%21" title="Pinterest">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=%E2%80%9CAMERICAN+HORROR+STORY%E2%80%9D+1984%3A+THE+THIRD+EPISODE+FINALE+EXPLAINED%21%21 %0A%0A https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/" title="WhatsApp">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/&title=%E2%80%9CAMERICAN+HORROR+STORY%E2%80%9D+1984%3A+THE+THIRD+EPISODE+FINALE+EXPLAINED%21%21" title="ReddIt">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content tagdiv-type">
<div class="td-post-featured-image"><figure><img width="650" height="366" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20366'%3E%3C/svg%3E" data-lazy-srcset="https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg 650w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-300x168.jpg 300w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-470x264.jpg 470w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-640x360.jpg 640w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-215x120.jpg 215w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-414x232.jpg 414w" data-lazy-sizes="(max-width: 650px) 100vw, 650px" alt="American horror story 1984" title="American horror story 1984" data-lazy-src="https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg" /><noscript><img width="650" height="366" class="entry-thumb" src="https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg" srcset="https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg 650w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-300x168.jpg 300w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-470x264.jpg 470w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-640x360.jpg 640w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-215x120.jpg 215w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-414x232.jpg 414w" sizes="(max-width: 650px) 100vw, 650px" alt="American horror story 1984" title="American horror story 1984"/></noscript><figcaption class="wp-caption-text">American horror story 1984</figcaption></figure></div>
<div class='code-block code-block-4' style='margin: 8px auto; text-align: center; display: block; clear: both; height: 270px; width: 100%;'>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2968280150811945" data-ad-slot="5841229554" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p style="text-align: justify;">American Horror Story: 1984 starts with several twists and turns, challenging the certainties of the fans. Thus, on the one hand there is a feeling of disorientation. On the other, there is a green light for the spectators&#8217; conjectures. Some of these have in fact tried to give an explanation to the final of the third episode of the FX brand show.</p>
<figure id="attachment_3379" aria-describedby="caption-attachment-3379" style="width: 650px" class="wp-caption aligncenter"><img class="size-full wp-image-3379" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20366'%3E%3C/svg%3E" alt="American horror story 1984" width="650" height="366" data-lazy-srcset="https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg 650w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-300x168.jpg 300w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-470x264.jpg 470w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-640x360.jpg 640w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-215x120.jpg 215w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-414x232.jpg 414w" data-lazy-sizes="(max-width: 650px) 100vw, 650px" data-lazy-src="https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg" /><noscript><img class="size-full wp-image-3379" src="https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg" alt="American horror story 1984" width="650" height="366" srcset="https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg 650w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-300x168.jpg 300w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-470x264.jpg 470w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-640x360.jpg 640w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-215x120.jpg 215w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-414x232.jpg 414w" sizes="(max-width: 650px) 100vw, 650px" /></noscript><figcaption id="caption-attachment-3379" class="wp-caption-text">American horror story 1984</figcaption></figure>
<p style="text-align: justify;">In the final moments, we see Montana, the character played by Billie Lourd. She comes face to face with Richard Ramirez ( Zach Villa ). Between the two takes a kiss and the woman asks the Night Stalker &#8221; why haven&#8217;t you killed her yet? &#8220;.</p>
<p style="text-align: justify;">Referring to Brooke ( Emma Roberts ), It also proves to be on the side of perpetrating the horrors in Camp Redwood. Apparently there is nobody that you can trust.</p><div class='code-block code-block-1' style='margin: 8px auto; text-align: center; display: block; clear: both; height:270px; width:100%;'>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2968280150811945" data-ad-slot="5841229554" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p style="text-align: justify;">As reported by Digital Spy, for some fans this evil chord seems to link to American Horror Story: Apocalypse. As we recall the one that was made between Dinah Stevens ( Adina Porter) and Pope Legba in which the woman asks for fame and success.</p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://asapland.com/amazon-removes-episode-70-of-shingeki-no-kyojin-due-to-controversy-in-japan/71352/" target="_self" rel="dofollow" class="u28a1b9fe978985d24b8b6ed25159b377"><style> .u28a1b9fe978985d24b8b6ed25159b377 { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:#eaeaea; border:0!important; border-left:4px solid #34495E!important; box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -moz-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -o-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -webkit-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); text-decoration:none; } .u28a1b9fe978985d24b8b6ed25159b377:active, .u28a1b9fe978985d24b8b6ed25159b377:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .u28a1b9fe978985d24b8b6ed25159b377 { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .u28a1b9fe978985d24b8b6ed25159b377 .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .u28a1b9fe978985d24b8b6ed25159b377 .postTitle { color:#000000; text-decoration: underline!important; font-size: 16px; } .u28a1b9fe978985d24b8b6ed25159b377:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">READ:</span>&nbsp; <span class="postTitle">Amazon removes episode 70 of Shingeki no Kyojin due to controversy in Japan</span></div></a></div><p style="text-align: justify;">Well, the hypothesis is that Richard Ramirez is in possession of powers that would allow him to fulfill Montana&#8217;s wishes. So in this view Brooke would have been chosen as a sacrifice. Thus To back up the thesis, The useful fact is that Brooke did define as &#8221; the last American virgin &#8220;.</p>
<p style="text-align: justify;">So that Montana claimed to want to become the biggest aerobic competitor of all time. The imagination of the fans is in full swing. So who knows if in this case, they saw us right.</p><div class='code-block code-block-1' style='margin: 8px auto; text-align: center; display: block; clear: both; height:270px; width:100%;'>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2968280150811945" data-ad-slot="5841229554" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p style="text-align: justify;">In recent days, Zach Villa reveals the difficulties of playing Night Stalker. A character based on the eponymous serial killer who really exists. The Killer was active in the years in which the last incarnation of the anthological series which Ryan Murphy directs is all set.</p>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both; height:270px; width:100%;'>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2968280150811945" data-ad-slot="5841229554" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

</div>
<footer>
 
<div class="td-post-source-tags">
  </div>
<div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-padding td-post-sharing-style2 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div>
<div class="td-social-but-text">Share</div>
</div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fasapland.com%2Famerican-horror-story-1984-the-third-episode-finale-explained%2F3377%2F" title="Facebook">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=%E2%80%9CAMERICAN+HORROR+STORY%E2%80%9D+1984%3A+THE+THIRD+EPISODE+FINALE+EXPLAINED%21%21&url=https%3A%2F%2Fasapland.com%2Famerican-horror-story-1984-the-third-episode-finale-explained%2F3377%2F&via=Asap+Land" title="Twitter">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/&amp;media=https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg&description=%E2%80%9CAMERICAN+HORROR+STORY%E2%80%9D+1984%3A+THE+THIRD+EPISODE+FINALE+EXPLAINED%21%21" title="Pinterest">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=%E2%80%9CAMERICAN+HORROR+STORY%E2%80%9D+1984%3A+THE+THIRD+EPISODE+FINALE+EXPLAINED%21%21 %0A%0A https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/" title="WhatsApp">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/&title=%E2%80%9CAMERICAN+HORROR+STORY%E2%80%9D+1984%3A+THE+THIRD+EPISODE+FINALE+EXPLAINED%21%21" title="ReddIt">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://asapland.com/marvels-runaways-summary-of-the-panel-at-the-new-york-comic-con/3352/">Marvel&#8217;s &#8220;Runaways&#8221;: Summary of The Panel At The New York Comic Con</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://asapland.com/halo-infinite-just-have-a-look-at-these-amazing-pictures-ign-first/3382/">Halo Infinite: Just Have a Look At These Amazing Pictures &#8211; IGN First</a></div></div></div> <div class="author-box-wrap"><a href="https://asapland.com/author/ryan/" aria-label="author-photo"><img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2096%2096'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/c92a5441de286727f20af27ecc654217?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' data-lazy-src="https://secure.gravatar.com/avatar/c92a5441de286727f20af27ecc654217?s=96&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/c92a5441de286727f20af27ecc654217?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/c92a5441de286727f20af27ecc654217?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></noscript></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://asapland.com/author/ryan/">Ryan Sanders</a></span></div><div class="td-author-description">Ryan is the guy who has been there with Lisa since the inception of Asap Land. When Lisa shared the idea of starting a news website, he loved the idea and took a plunge into writing online news bulletins. He is now having quite good experience with sharing news in its original form.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Ryan Sanders"></span><meta itemprop="datePublished" content="2021-10-07T01:39:18-04:00"><meta itemprop="dateModified" content="2021-10-07T01:39:46-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://asapland.com/wp-content/uploads/2019/05/asapland.png"></span><meta itemprop="name" content="Asap Land"></span><meta itemprop="headline " content="&quot;AMERICAN HORROR STORY&quot; 1984: THE THIRD EPISODE FINALE EXPLAINED!!"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984.jpg"><meta itemprop="width" content="650"><meta itemprop="height" content="366"></span> </footer>
</article> 
<div class="td_block_wrap td_block_related_posts tdi_2 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_2"><script type="rocketlazyloadscript">var block_tdi_2 = new tdBlock();
block_tdi_2.id = "tdi_2";
block_tdi_2.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_2","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":3377,"live_filter_cur_post_author":"6","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_2","tdc_css_class_style":"tdi_2_rand_style"}';
block_tdi_2.td_column_number = "3";
block_tdi_2.block_type = "td_block_related_posts";
block_tdi_2.post_count = "3";
block_tdi_2.found_posts = "2654";
block_tdi_2.header_color = "";
block_tdi_2.ajax_pagination_infinite_stop = "";
block_tdi_2.max_num_pages = "885";
tdBlocksArray.push(block_tdi_2);
</script><h4 class="td-related-title td-block-title"><a id="tdi_3" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_2" href="#">RELATED ARTICLES</a><a id="tdi_4" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_2" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_2 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://asapland.com/the-reason-behind-break-up-of-kylie-jenner-and-travis-scott-is-revealed-is-she-dating-someone/3388/" rel="bookmark" class="td-image-wrap " title="The Reason Behind Break-Up of &#8220;Kylie Jenner&#8221; and &#8220;Travis Scott&#8221; is Revealed!! IS SHE DATING SOMEONE?"><img width="218" height="150" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E" data-lazy-srcset="https://asapland.com/wp-content/uploads/2019/10/kylie-jenner-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/kylie-jenner-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/kylie-jenner-379x259.jpg 379w" data-lazy-sizes="(max-width: 218px) 100vw, 218px" alt="kylie jenner" title="The Reason Behind Break-Up of &#8220;Kylie Jenner&#8221; and &#8220;Travis Scott&#8221; is Revealed!! IS SHE DATING SOMEONE?" data-lazy-src="https://asapland.com/wp-content/uploads/2019/10/kylie-jenner-218x150.jpg" /><noscript><img width="218" height="150" class="entry-thumb" src="https://asapland.com/wp-content/uploads/2019/10/kylie-jenner-218x150.jpg"  srcset="https://asapland.com/wp-content/uploads/2019/10/kylie-jenner-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/kylie-jenner-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/kylie-jenner-379x259.jpg 379w" sizes="(max-width: 218px) 100vw, 218px"  alt="kylie jenner" title="The Reason Behind Break-Up of &#8220;Kylie Jenner&#8221; and &#8220;Travis Scott&#8221; is Revealed!! IS SHE DATING SOMEONE?" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://asapland.com/the-reason-behind-break-up-of-kylie-jenner-and-travis-scott-is-revealed-is-she-dating-someone/3388/" rel="bookmark" title="The Reason Behind Break-Up of &#8220;Kylie Jenner&#8221; and &#8220;Travis Scott&#8221; is Revealed!! IS SHE DATING SOMEONE?">The Reason Behind Break-Up of &#8220;Kylie Jenner&#8221; and &#8220;Travis Scott&#8221; is Revealed!! IS SHE DATING SOMEONE?</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://asapland.com/halo-infinite-just-have-a-look-at-these-amazing-pictures-ign-first/3382/" rel="bookmark" class="td-image-wrap " title="Halo Infinite: Just Have a Look At These Amazing Pictures &#8211; IGN First"><img width="218" height="150" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E" data-lazy-srcset="https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-550x377.jpg 550w, https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-379x259.jpg 379w" data-lazy-sizes="(max-width: 218px) 100vw, 218px" alt="Halo Infinite" title="Halo Infinite: Just Have a Look At These Amazing Pictures &#8211; IGN First" data-lazy-src="https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-218x150.jpg" /><noscript><img width="218" height="150" class="entry-thumb" src="https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-218x150.jpg"  srcset="https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-550x377.jpg 550w, https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-379x259.jpg 379w" sizes="(max-width: 218px) 100vw, 218px"  alt="Halo Infinite" title="Halo Infinite: Just Have a Look At These Amazing Pictures &#8211; IGN First" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://asapland.com/halo-infinite-just-have-a-look-at-these-amazing-pictures-ign-first/3382/" rel="bookmark" title="Halo Infinite: Just Have a Look At These Amazing Pictures &#8211; IGN First">Halo Infinite: Just Have a Look At These Amazing Pictures &#8211; IGN First</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://asapland.com/marvels-runaways-summary-of-the-panel-at-the-new-york-comic-con/3352/" rel="bookmark" class="td-image-wrap " title="Marvel&#8217;s &#8220;Runaways&#8221;: Summary of The Panel At The New York Comic Con"><img width="218" height="150" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E" data-lazy-srcset="https://asapland.com/wp-content/uploads/2019/10/Marvel-Runaways-NYCC-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/Marvel-Runaways-NYCC-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/Marvel-Runaways-NYCC-379x259.jpg 379w" data-lazy-sizes="(max-width: 218px) 100vw, 218px" alt="Marvel Runaways NYCC" title="Marvel&#8217;s &#8220;Runaways&#8221;: Summary of The Panel At The New York Comic Con" data-lazy-src="https://asapland.com/wp-content/uploads/2019/10/Marvel-Runaways-NYCC-218x150.jpg" /><noscript><img width="218" height="150" class="entry-thumb" src="https://asapland.com/wp-content/uploads/2019/10/Marvel-Runaways-NYCC-218x150.jpg"  srcset="https://asapland.com/wp-content/uploads/2019/10/Marvel-Runaways-NYCC-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/Marvel-Runaways-NYCC-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/Marvel-Runaways-NYCC-379x259.jpg 379w" sizes="(max-width: 218px) 100vw, 218px"  alt="Marvel Runaways NYCC" title="Marvel&#8217;s &#8220;Runaways&#8221;: Summary of The Panel At The New York Comic Con" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://asapland.com/marvels-runaways-summary-of-the-panel-at-the-new-york-comic-con/3352/" rel="bookmark" title="Marvel&#8217;s &#8220;Runaways&#8221;: Summary of The Panel At The New York Comic Con">Marvel&#8217;s &#8220;Runaways&#8221;: Summary of The Panel At The New York Comic Con</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_2" data-td_block_id="tdi_2"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_2" data-td_block_id="tdi_2"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div> 
<div class="comments" id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/american-horror-story-1984-the-third-episode-finale-explained/3377/#respond" style="display:none;">Cancel reply</a></small></h3><form action="" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
<div class="comment-form-input-wrap td-form-comment">
<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
<div class="td-warning-comment">Please enter your comment!</div>
</div>
<div class="comment-form-input-wrap td-form-author">
<input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-author">Please enter your name here</div>
</div>
<div class="comment-form-input-wrap td-form-email">
<input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-email-error">You have entered an incorrect email address!</div>
<div class="td-warning-email">Please enter your email address here</div>
</div>
<div class="comment-form-input-wrap td-form-url">
<input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
</div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='3377' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form> </div>
 </div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside id="search-2" class="td_block_template_1 widget search-2 widget_search"><form method="get" class="td-search-form-widget" action="https://asapland.com/">
<div role="search">
<input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
</div>
</form></aside><aside id="text-2" class="td_block_template_1 widget text-2 widget_text"><h4 class="block-title"><span>Get in Touch!</span></h4> <div class="textwidget"><p>To get in touch with <strong>Asap Land</strong>, please write to <a href="/cdn-cgi/l/email-protection#1a7673697b7e6f687b746e71693a5a3a7d777b73763479757710">lisadurantks @ gmail.com<br />
</a>. We will try our best to respond quickly. However, expect around 24 hours to get a response.</p>
</div>
</aside><div class="td_block_wrap td_block_7 td_block_widget tdi_5 td-pb-border-top td_block_template_1 td-column-1 td_block_padding" data-td-block-uid="tdi_5"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript">var block_tdi_5 = new tdBlock();
block_tdi_5.id = "tdi_5";
block_tdi_5.atts = '{"custom_title":"Related News","custom_url":"","block_template_id":"","header_color":"#","header_text_color":"#","accent_text_color":"#","m6_tl":"","limit":"8","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_5","block_type":"td_block_7","separator":"","show_modified_date":"","time_ago":"","time_ago_add_txt":"ago","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"tdi_5","tdc_css_class_style":"tdi_5_rand_style"}';
block_tdi_5.td_column_number = "1";
block_tdi_5.block_type = "td_block_7";
block_tdi_5.post_count = "8";
block_tdi_5.found_posts = "3761";
block_tdi_5.header_color = "#";
block_tdi_5.ajax_pagination_infinite_stop = "";
block_tdi_5.max_num_pages = "471";
tdBlocksArray.push(block_tdi_5);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">Related News</span></h4></div><div id=tdi_5 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://asapland.com/the-reason-behind-break-up-of-kylie-jenner-and-travis-scott-is-revealed-is-she-dating-someone/3388/" rel="bookmark" class="td-image-wrap " title="The Reason Behind Break-Up of &#8220;Kylie Jenner&#8221; and &#8220;Travis Scott&#8221; is Revealed!! IS SHE DATING SOMEONE?"><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E" data-lazy-srcset="https://asapland.com/wp-content/uploads/2019/10/kylie-jenner-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/kylie-jenner-218x150.jpg 218w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" alt="kylie jenner" title="The Reason Behind Break-Up of &#8220;Kylie Jenner&#8221; and &#8220;Travis Scott&#8221; is Revealed!! IS SHE DATING SOMEONE?" data-lazy-src="https://asapland.com/wp-content/uploads/2019/10/kylie-jenner-100x70.jpg" /><noscript><img width="100" height="70" class="entry-thumb" src="https://asapland.com/wp-content/uploads/2019/10/kylie-jenner-100x70.jpg"  srcset="https://asapland.com/wp-content/uploads/2019/10/kylie-jenner-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/kylie-jenner-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="kylie jenner" title="The Reason Behind Break-Up of &#8220;Kylie Jenner&#8221; and &#8220;Travis Scott&#8221; is Revealed!! IS SHE DATING SOMEONE?" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://asapland.com/the-reason-behind-break-up-of-kylie-jenner-and-travis-scott-is-revealed-is-she-dating-someone/3388/" rel="bookmark" title="The Reason Behind Break-Up of &#8220;Kylie Jenner&#8221; and &#8220;Travis Scott&#8221; is Revealed!! IS SHE DATING SOMEONE?">The Reason Behind Break-Up of &#8220;Kylie Jenner&#8221; and &#8220;Travis Scott&#8221; is...</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-10-07T03:14:41-04:00">October 7, 2021</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://asapland.com/halo-infinite-just-have-a-look-at-these-amazing-pictures-ign-first/3382/" rel="bookmark" class="td-image-wrap " title="Halo Infinite: Just Have a Look At These Amazing Pictures &#8211; IGN First"><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E" data-lazy-srcset="https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-534x377.jpg 534w, https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-550x377.jpg 550w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" alt="Halo Infinite" title="Halo Infinite: Just Have a Look At These Amazing Pictures &#8211; IGN First" data-lazy-src="https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-100x70.jpg" /><noscript><img width="100" height="70" class="entry-thumb" src="https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-100x70.jpg"  srcset="https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-534x377.jpg 534w, https://asapland.com/wp-content/uploads/2019/10/Halo-Infinite-550x377.jpg 550w" sizes="(max-width: 100px) 100vw, 100px"  alt="Halo Infinite" title="Halo Infinite: Just Have a Look At These Amazing Pictures &#8211; IGN First" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://asapland.com/halo-infinite-just-have-a-look-at-these-amazing-pictures-ign-first/3382/" rel="bookmark" title="Halo Infinite: Just Have a Look At These Amazing Pictures &#8211; IGN First">Halo Infinite: Just Have a Look At These Amazing Pictures &#8211;...</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-10-07T01:56:44-04:00">October 7, 2021</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/" rel="bookmark" class="td-image-wrap " title="&#8220;AMERICAN HORROR STORY&#8221; 1984: THE THIRD EPISODE FINALE EXPLAINED!!"><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E" data-lazy-srcset="https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-534x366.jpg 534w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" alt="American horror story 1984" title="&#8220;AMERICAN HORROR STORY&#8221; 1984: THE THIRD EPISODE FINALE EXPLAINED!!" data-lazy-src="https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-100x70.jpg" /><noscript><img width="100" height="70" class="entry-thumb" src="https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-100x70.jpg"  srcset="https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/American-horror-story-1984-534x366.jpg 534w" sizes="(max-width: 100px) 100vw, 100px"  alt="American horror story 1984" title="&#8220;AMERICAN HORROR STORY&#8221; 1984: THE THIRD EPISODE FINALE EXPLAINED!!" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://asapland.com/american-horror-story-1984-the-third-episode-finale-explained/3377/" rel="bookmark" title="&#8220;AMERICAN HORROR STORY&#8221; 1984: THE THIRD EPISODE FINALE EXPLAINED!!">&#8220;AMERICAN HORROR STORY&#8221; 1984: THE THIRD EPISODE FINALE EXPLAINED!!</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-10-07T01:39:18-04:00">October 7, 2021</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://asapland.com/marvels-runaways-summary-of-the-panel-at-the-new-york-comic-con/3352/" rel="bookmark" class="td-image-wrap " title="Marvel&#8217;s &#8220;Runaways&#8221;: Summary of The Panel At The New York Comic Con"><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E" data-lazy-srcset="https://asapland.com/wp-content/uploads/2019/10/Marvel-Runaways-NYCC-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/Marvel-Runaways-NYCC-218x150.jpg 218w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" alt="Marvel Runaways NYCC" title="Marvel&#8217;s &#8220;Runaways&#8221;: Summary of The Panel At The New York Comic Con" data-lazy-src="https://asapland.com/wp-content/uploads/2019/10/Marvel-Runaways-NYCC-100x70.jpg" /><noscript><img width="100" height="70" class="entry-thumb" src="https://asapland.com/wp-content/uploads/2019/10/Marvel-Runaways-NYCC-100x70.jpg"  srcset="https://asapland.com/wp-content/uploads/2019/10/Marvel-Runaways-NYCC-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/Marvel-Runaways-NYCC-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="Marvel Runaways NYCC" title="Marvel&#8217;s &#8220;Runaways&#8221;: Summary of The Panel At The New York Comic Con" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://asapland.com/marvels-runaways-summary-of-the-panel-at-the-new-york-comic-con/3352/" rel="bookmark" title="Marvel&#8217;s &#8220;Runaways&#8221;: Summary of The Panel At The New York Comic Con">Marvel&#8217;s &#8220;Runaways&#8221;: Summary of The Panel At The New York Comic...</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-10-06T22:27:37-04:00">October 6, 2021</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://asapland.com/marvels-runaways-season-3-teaser-and-new-poster/3343/" rel="bookmark" class="td-image-wrap " title="Marvel&#8217;s &#8220;Runaways&#8221; Season 3: Teaser and New Poster"><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E" data-lazy-srcset="https://asapland.com/wp-content/uploads/2019/10/marvels-runaways-season-3-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/marvels-runaways-season-3-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/marvels-runaways-season-3-550x390.jpg 550w, https://asapland.com/wp-content/uploads/2019/10/marvels-runaways-season-3-559x390.jpg 559w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" alt="marvels runaways season 3" title="Marvel&#8217;s &#8220;Runaways&#8221; Season 3: Teaser and New Poster" data-lazy-src="https://asapland.com/wp-content/uploads/2019/10/marvels-runaways-season-3-100x70.jpg" /><noscript><img width="100" height="70" class="entry-thumb" src="https://asapland.com/wp-content/uploads/2019/10/marvels-runaways-season-3-100x70.jpg"  srcset="https://asapland.com/wp-content/uploads/2019/10/marvels-runaways-season-3-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/marvels-runaways-season-3-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/marvels-runaways-season-3-550x390.jpg 550w, https://asapland.com/wp-content/uploads/2019/10/marvels-runaways-season-3-559x390.jpg 559w" sizes="(max-width: 100px) 100vw, 100px"  alt="marvels runaways season 3" title="Marvel&#8217;s &#8220;Runaways&#8221; Season 3: Teaser and New Poster" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://asapland.com/marvels-runaways-season-3-teaser-and-new-poster/3343/" rel="bookmark" title="Marvel&#8217;s &#8220;Runaways&#8221; Season 3: Teaser and New Poster">Marvel&#8217;s &#8220;Runaways&#8221; Season 3: Teaser and New Poster</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-10-06T20:52:42-04:00">October 6, 2021</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://asapland.com/elite-season-3-everything-we-know-till-now/3324/" rel="bookmark" class="td-image-wrap " title="Elite Season 3: Everything We Know Till Now!!"><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E" data-lazy-srcset="https://asapland.com/wp-content/uploads/2019/10/elite-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/elite-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/elite-534x366.jpg 534w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" alt="Elite" title="Elite Season 3: Everything We Know Till Now!!" data-lazy-src="https://asapland.com/wp-content/uploads/2019/10/elite-100x70.jpg" /><noscript><img width="100" height="70" class="entry-thumb" src="https://asapland.com/wp-content/uploads/2019/10/elite-100x70.jpg"  srcset="https://asapland.com/wp-content/uploads/2019/10/elite-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/elite-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/elite-534x366.jpg 534w" sizes="(max-width: 100px) 100vw, 100px"  alt="Elite" title="Elite Season 3: Everything We Know Till Now!!" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://asapland.com/elite-season-3-everything-we-know-till-now/3324/" rel="bookmark" title="Elite Season 3: Everything We Know Till Now!!">Elite Season 3: Everything We Know Till Now!!</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-10-06T18:19:34-04:00">October 6, 2021</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://asapland.com/in-arrows-last-season-colton-haynes-will-return-as-roy-harper/3336/" rel="bookmark" class="td-image-wrap " title="In Arrow&#8217;s Last Season &#8220;Colton Haynes&#8221; will return as &#8220;Roy Harper&#8221;"><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E" data-lazy-srcset="https://asapland.com/wp-content/uploads/2019/10/Roy-Harper-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/Roy-Harper-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/Roy-Harper-459x325.jpg 459w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" alt="Roy Harper" title="In Arrow&#8217;s Last Season &#8220;Colton Haynes&#8221; will return as &#8220;Roy Harper&#8221;" data-lazy-src="https://asapland.com/wp-content/uploads/2019/10/Roy-Harper-100x70.jpg" /><noscript><img width="100" height="70" class="entry-thumb" src="https://asapland.com/wp-content/uploads/2019/10/Roy-Harper-100x70.jpg"  srcset="https://asapland.com/wp-content/uploads/2019/10/Roy-Harper-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/Roy-Harper-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/Roy-Harper-459x325.jpg 459w" sizes="(max-width: 100px) 100vw, 100px"  alt="Roy Harper" title="In Arrow&#8217;s Last Season &#8220;Colton Haynes&#8221; will return as &#8220;Roy Harper&#8221;" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://asapland.com/in-arrows-last-season-colton-haynes-will-return-as-roy-harper/3336/" rel="bookmark" title="In Arrow&#8217;s Last Season &#8220;Colton Haynes&#8221; will return as &#8220;Roy Harper&#8221;">In Arrow&#8217;s Last Season &#8220;Colton Haynes&#8221; will return as &#8220;Roy Harper&#8221;</a></h3> <div class="td-module-meta-info">
 <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-10-06T18:02:32-04:00">October 6, 2021</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://asapland.com/release-date-is-known-for-season-3-of-elite-it-will-return-to-las-encinas-in-2020-with-two-new-students/3331/" rel="bookmark" class="td-image-wrap " title="Release Date is known for Season 3 of &#8216;Elite&#8217;: It will return to Las Encinas in 2020 with Two New Students"><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E" data-lazy-srcset="https://asapland.com/wp-content/uploads/2019/10/elite-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/elite-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/elite-534x366.jpg 534w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" alt="Elite" title="Release Date is known for Season 3 of &#8216;Elite&#8217;: It will return to Las Encinas in 2020 with Two New Students" data-lazy-src="https://asapland.com/wp-content/uploads/2019/10/elite-100x70.jpg" /><noscript><img width="100" height="70" class="entry-thumb" src="https://asapland.com/wp-content/uploads/2019/10/elite-100x70.jpg"  srcset="https://asapland.com/wp-content/uploads/2019/10/elite-100x70.jpg 100w, https://asapland.com/wp-content/uploads/2019/10/elite-218x150.jpg 218w, https://asapland.com/wp-content/uploads/2019/10/elite-534x366.jpg 534w" sizes="(max-width: 100px) 100vw, 100px"  alt="Elite" title="Release Date is known for Season 3 of &#8216;Elite&#8217;: It will return to Las Encinas in 2020 with Two New Students" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://asapland.com/release-date-is-known-for-season-3-of-elite-it-will-return-to-las-encinas-in-2020-with-two-new-students/3331/" rel="bookmark" title="Release Date is known for Season 3 of &#8216;Elite&#8217;: It will return to Las Encinas in 2020 with Two New Students">Release Date is known for Season 3 of &#8216;Elite&#8217;: It will...</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-10-06T15:20:20-04:00">October 6, 2021</time></span> </div>
</div>
</div>
</div> </div></div> <aside id="top-posts-2" class="td_block_template_1 widget top-posts-2 widget_top-posts"><h4 class="block-title"><span>You May Like</span></h4><ul> <li>
<a href="https://asapland.com/game-of-thrones-nathalie-emmanuel-admits-that-there-should-have-been-more-diversity/3155/" class="bump-view" data-bump-view="tp">GAME OF THRONES: NATHALIE EMMANUEL ADMITS THAT THERE SHOULD HAVE BEEN MORE DIVERSITY</a> </li>
<li>
<a href="https://asapland.com/the-benefits-and-harms-of-popcorn/77386/" class="bump-view" data-bump-view="tp">The benefits and harms of Popcorn</a> </li>
<li>
<a href="https://asapland.com/cucumber-benefits-for-health/77438/" class="bump-view" data-bump-view="tp">Cucumber Benefits for Health</a> </li>
<li>
<a href="https://asapland.com/health-benefits-of-lemon-juice/77434/" class="bump-view" data-bump-view="tp">Health Benefits of Lemon Juice</a> </li>
<li>
<a href="https://asapland.com/eminems-daughter-hailie-mathers-looks-exactly-like-him-in-a-recent-instagram-photo/3241/" class="bump-view" data-bump-view="tp">Eminem&#039;s Daughter Hailie Mathers Looks Exactly Like Him in A Recent Instagram Photo</a> </li>
<li>
<a href="https://asapland.com/2-chains-humiliate-tekashi-6ix9ine-in-all-nyc-ways-possible-by-calling-him-rat/3070/" class="bump-view" data-bump-view="tp">2 Chains Humiliate Tekashi 6ix9ine in All NYC Ways Possible By Calling Him &quot;Rat&quot;</a> </li>
<li>
<a href="https://asapland.com/hazbin-hotel-episode-2-release-date/69175/" class="bump-view" data-bump-view="tp">Hazbin Hotel Episode 2: Release Date, Characters, and Everything You Should Know</a> </li>
<li>
<a href="https://asapland.com/joker-ending-explained-what-really-happened/3204/" class="bump-view" data-bump-view="tp">&quot;Joker&quot; Ending Explained: What Really Happened?</a> </li>
<li>
<a href="https://asapland.com/first-wedding-photos-of-justin-bieber-and-hailey-baldwin-with-her-beautiful-wedding-dress/3062/" class="bump-view" data-bump-view="tp">First wedding photos of Justin Bieber and Hailey Baldwin with Her Beautiful Wedding Dress</a> </li>
<li>
<a href="https://asapland.com/prince-harry-snaps-at-reporter-in-the-middle-of-tension-with-press/3208/" class="bump-view" data-bump-view="tp">Prince Harry Snaps At Reporter In The Middle Of Tension With Press</a> </li>
</ul></aside> </div>
</div>
</div> 
</div> 
</div> 

<div class="tdc-footer-wrap ">

<div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-9 ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span4">
</div>
<div class="td-pb-span4">
</div>
<div class="td-pb-span4">
</div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
<div class="menu-page-menu-container"><ul id="menu-page-menu" class="td-subfooter-menu"><li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-129"><a href="https://asapland.com/home/">Home</a></li>
<li id="menu-item-378" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-378"><a href="https://asapland.com/about/">About</a></li>
<li id="menu-item-369" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-369"><a href="https://asapland.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-370" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-370"><a href="https://asapland.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-372" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-372"><a href="https://asapland.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-2242" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-2242"><a href="https://asapland.com/team/">Team</a></li>
<li id="menu-item-2241" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-2241"><a href="https://asapland.com/contact/">Contact</a></li>
</ul></div> </div>
<div class="td-pb-span td-sub-footer-copy">
&copy; Copyright © 2019 Asap Land. </div>
</div>
</div>
</div>
</div>
</div>

<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://asapland.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.7' id='regenerator-runtime-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://asapland.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/asapland.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://asapland.com/wp-content/cache/min/1/wp-content/plugins/contact-form-7/includes/js/index.js?ver=1632744145' id='contact-form-7-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/asapland.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://asapland.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.2' id='td-site-min-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://asapland.com/wp-includes/js/comment-reply.min.js?ver=5.8.1' id='comment-reply-js' defer></script>
<script type="rocketlazyloadscript">let commentForm = document.querySelector("#commentform, #ast-commentform, #fl-comment-form, #ht-commentform");document.onscroll = function () {commentForm.action = "/wp-comments-post.php?40d1b2d83998fabacb726e5bc3d22129";};</script>

<script type="rocketlazyloadscript">
    
</script>
<script src='https://stats.wp.com/e-202140.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.2',blog:'165120369',post:'3377',tz:'-4',srv:'asapland.com'} ]);
	_stq.push([ 'clickTrackerInit', '165120369', '3377' ]);
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://asapland.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img loading="lazy" data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script>
</body>
</html>
