<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Everything We Know About &#039;The Righteous Gemstones&#039; Season 2 - Asap Land</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://asapland.com/wp-content/cache/min/1/5ee5c858f0a84d0dc41a5ba40c120fd1.css" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" media="all" data-minify="1" />
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://asapland.com/xmlrpc.php" />
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v16.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<link rel="canonical" href="https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Everything We Know About &#039;The Righteous Gemstones&#039; Season 2 - Asap Land" />
	<meta property="og:description" content="Everything We Know About &#8216;The Righteous Gemstones&#8217; Season 2 This series is a black comedy which includes so much drama and comedy about a reverent family and whose first season was super amazing for everybody. Also, this series sometimes follows criminal activities with so many adventures also, they shared a successes night with HBO on [&hellip;]" />
	<meta property="og:url" content="https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/" />
	<meta property="og:site_name" content="Asap Land" />
	<meta property="article:published_time" content="2021-05-10T17:03:42+00:00" />
	<meta property="article:modified_time" content="2021-05-10T16:09:12+00:00" />
	<meta property="og:image" content="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?fit=650%2C431&#038;ssl=1" />
	<meta property="og:image:width" content="650" />
	<meta property="og:image:height" content="431" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Maria Rivera">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="2 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://asapland.com/#organization","name":"ASAP Land News","url":"https://asapland.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://asapland.com/#logo","inLanguage":"en-US","url":"https://i2.wp.com/asapland.com/wp-content/uploads/2019/05/asapland_small.jpg?fit=100%2C30&ssl=1","contentUrl":"https://i2.wp.com/asapland.com/wp-content/uploads/2019/05/asapland_small.jpg?fit=100%2C30&ssl=1","width":100,"height":30,"caption":"ASAP Land News"},"image":{"@id":"https://asapland.com/#logo"}},{"@type":"WebSite","@id":"https://asapland.com/#website","url":"https://asapland.com/","name":"Asap Land","description":"Instant News Portal","publisher":{"@id":"https://asapland.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://asapland.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?fit=650%2C431&ssl=1","contentUrl":"https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?fit=650%2C431&ssl=1","width":650,"height":431},{"@type":"WebPage","@id":"https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/#webpage","url":"https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/","name":"Everything We Know About 'The Righteous Gemstones' Season 2 - Asap Land","isPartOf":{"@id":"https://asapland.com/#website"},"primaryImageOfPage":{"@id":"https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/#primaryimage"},"datePublished":"2021-05-10T17:03:42+00:00","dateModified":"2021-05-10T16:09:12+00:00","breadcrumb":{"@id":"https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/"]}]},{"@type":"BreadcrumbList","@id":"https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://asapland.com/","url":"https://asapland.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/#webpage"}}]},{"@type":"Article","@id":"https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/#article","isPartOf":{"@id":"https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/#webpage"},"author":{"@id":"https://asapland.com/#/schema/person/21089f738a5b4178e6260d6f83e8c509"},"headline":"Everything We Know About &#8216;The Righteous Gemstones&#8217; Season 2","datePublished":"2021-05-10T17:03:42+00:00","dateModified":"2021-05-10T16:09:12+00:00","mainEntityOfPage":{"@id":"https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/#webpage"},"commentCount":0,"publisher":{"@id":"https://asapland.com/#organization"},"image":{"@id":"https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/#primaryimage"},"articleSection":["Entertainment"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/#respond"]}]},{"@type":"Person","@id":"https://asapland.com/#/schema/person/21089f738a5b4178e6260d6f83e8c509","name":"Maria Rivera","image":{"@type":"ImageObject","@id":"https://asapland.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/2ab502300203a26505fd95f7eb9d27c0?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/2ab502300203a26505fd95f7eb9d27c0?s=96&d=mm&r=g","caption":"Maria Rivera"},"description":"Maria is the youngest team member of Asap Land. She joined as an intern as she was having a diploma in journalism. But, now as she gained experience, she is working as full-time editor and contributor on Asap Land. She loves to write news bulletins from the business world as she is quite fascinated with business."}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel="amphtml" href="https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/amp/" /><meta name="generator" content="AMP for WP 1.0.76.15"/><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Asap Land &raquo; Feed" href="https://asapland.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Asap Land &raquo; Comments Feed" href="https://asapland.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Asap Land &raquo; Everything We Know About &#8216;The Righteous Gemstones&#8217; Season 2 Comments Feed" href="https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>


<link rel='preload'   href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=10.3.3' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />

<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>



<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://asapland.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>

<script type='text/javascript' src='https://c0.wp.com/c/5.7.1/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>

<link rel="https://api.w.org/" href="https://asapland.com/wp-json/" /><link rel="alternate" type="application/json" href="https://asapland.com/wp-json/wp/v2/posts/76270" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://asapland.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://asapland.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.1" />
<link rel='shortlink' href='https://wp.me/pbaPlL-jQa' />
<style type='text/css'>img#wpstats{display:none}</style>
		<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"cc186ef912","wpRestUrl":"https:\/\/asapland.com\/wp-json\/","permalinkStructure":"\/%postname%\/%post_id%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"on","origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/asapland.com\/wp-admin\/","wpRestNonce":"cc186ef912","wpRestUrl":"https:\/\/asapland.com\/wp-json\/","permalinkStructure":"\/%postname%\/%post_id%\/"};
			</script>
			
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script data-no-minify="1" async src="https://asapland.com/wp-content/cache/busting/1/gtm-d50a7f43ce53cfb81ff2182712f55242.js"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-144838927-1');
</script>
<meta name="google-site-verification" content="XI4PbxYziSgQfs68Re_vYSAz1T67jTyqsx7NrRhzb20" />


<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://asapland.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://asapland.com/category/entertainment/",
                    "name": "Entertainment"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/",
                    "name": "Everything We Know About &#8216;The Righteous Gemstones&#8217; Season 2"                                
                }
            }    
        ]
    }
</script>

<!-- Button style compiled by theme -->

<style>
    
</style>

	<style id="tdw-css-placeholder">.td-page-content p,
.td-post-content p,
.wpb_text_column p,
.td_block_text_with_title p,
.woocommerce #tab-description p,
.mce-content-body p,
.td-page-content li,
.td-post-content li,
.wpb_text_column li,
.td_block_text_with_title li,
.woocommerce #tab-description li,
.mce-content-body li {
  font-size: 17px;
  line-height: 26px;
}
.td_module_6 .entry-title {
  font-size: 16px;
}
</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script>
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head>

<body class="post-template-default single single-post postid-76270 single-format-standard td-standard-pack everything-we-know-about-the-righteous-gemstones-season-2 global-block-template-1 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-cat-menu-container"><ul id="menu-cat-menu" class="td-mobile-main-menu"><li id="menu-item-373" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-373"><a href="https://asapland.com">Home</a></li>
<li id="menu-item-130" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130"><a href="https://asapland.com/category/business/">Business</a></li>
<li id="menu-item-132" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-132"><a href="https://asapland.com/category/technology/">Technology</a></li>
<li id="menu-item-131" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131"><a href="https://asapland.com/category/general-news/">General News</a></li>
<li id="menu-item-746" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-746"><a href="https://asapland.com/category/entertainment/">Entertainment</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                <div class="td-login-register-link">
	                
	                </div>
	                
	                

                </div>
            </div>

            
            
            
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://asapland.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 10
-->

<div class="td-header-wrap td-header-style-10 ">
    
    
    <div class="td-banner-wrap-full td-logo-wrap-full td-logo-mobile-loaded td-container-wrap ">
        <div class="td-header-sp-logo">
            		<a class="td-main-logo" href="https://asapland.com/">
			<img class="td-retina-data"  data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland.png" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%200'%3E%3C/svg%3E" alt="" width="300" data-lazy-src="https://asapland.com/wp-content/uploads/2019/05/asapland.png"/><noscript><img class="td-retina-data"  data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland.png" src="https://asapland.com/wp-content/uploads/2019/05/asapland.png" alt="" width="300"/></noscript>
			<span class="td-visual-hidden">Asap Land</span>
		</a>
	        </div>
    </div>

	<div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient ">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-header" href="https://asapland.com/">
			<img class="td-retina-data" data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland_small.jpg" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://asapland.com/wp-content/uploads/2019/05/asapland_small.jpg"/><noscript><img class="td-retina-data" data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland_small.jpg" src="https://asapland.com/wp-content/uploads/2019/05/asapland_small.jpg" alt=""/></noscript>
		</a>
			<a class="td-header-logo td-sticky-header" href="https://asapland.com/">
			<img class="td-retina-data" data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland.png" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://asapland.com/wp-content/uploads/2019/05/asapland.png"/><noscript><img class="td-retina-data" data-retina="https://asapland.com/wp-content/uploads/2019/05/asapland.png" src="https://asapland.com/wp-content/uploads/2019/05/asapland.png" alt=""/></noscript>
		</a>
	    </div>
    <div class="menu-cat-menu-container"><ul id="menu-cat-menu-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-373"><a href="https://asapland.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-130"><a href="https://asapland.com/category/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-132"><a href="https://asapland.com/category/technology/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-131"><a href="https://asapland.com/category/general-news/">General News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-746"><a href="https://asapland.com/category/entertainment/">Entertainment</a></li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://asapland.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
			</div>
		</div>
	</div>

            <div class="td-banner-wrap-full td-banner-bg td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header tdi_1_690 td_block_template_1 ">

<style>
/* custom css */
.tdi_1_690.td-a-rec{
					text-align: center;
				}.tdi_1_690 .td-element-style{
					z-index: -1;
				}.tdi_1_690.td-a-rec-img{
				    text-align: left;
				}.tdi_1_690.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1_690.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-2968280150811945" data-ad-slot="8351339600"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2968280150811945" data-ad-slot="8351339600"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2968280150811945" data-ad-slot="8351339600"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-2968280150811945" data-ad-slot="8351339600"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 


</div>                </div>
            </div>
        </div>
    
</div>
            </div>

            
    <div class="td-main-content-wrap td-container-wrap">

        <div class="td-container td-post-template-default ">
            <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://asapland.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Entertainment" class="entry-crumb" href="https://asapland.com/category/entertainment/">Entertainment</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Everything We Know About &#8216;The Righteous Gemstones&#8217; Season 2</span></div></div>

            <div class="td-pb-row">
                                        <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-76270" class="post-76270 post type-post status-publish format-standard has-post-thumbnail category-entertainment" itemscope itemtype="https://schema.org/Article"47>
        <div class="td-post-header">

            <!-- category --><ul class="td-category"><li class="entry-category"><a  href="https://asapland.com/category/entertainment/">Entertainment</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Everything We Know About &#8216;The Righteous Gemstones&#8217; Season 2</h1>
                

                <div class="td-module-meta-info">
                    <!-- author --><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://asapland.com/author/maria/">Maria Rivera</a><div class="td-author-line"> - </div> </div>                    <!-- date --><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-05-10T13:03:42-04:00" >May 10, 2021</time></span>                    <!-- comments -->                    <!-- views -->                </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-padding td-post-sharing-style2 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fasapland.com%2Feverything-we-know-about-the-righteous-gemstones-season-2%2F76270%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Everything+We+Know+About+%E2%80%98The+Righteous+Gemstones%E2%80%99+Season+2&url=https%3A%2F%2Fasapland.com%2Feverything-we-know-about-the-righteous-gemstones-season-2%2F76270%2F&via=Asap+Land">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/&amp;media=https://asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg&description=Everything+We+Know+About+%E2%80%98The+Righteous+Gemstones%E2%80%99+Season+2">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Everything+We+Know+About+%E2%80%98The+Righteous+Gemstones%E2%80%99+Season+2 %0A%0A https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/&title=Everything+We+Know+About+%E2%80%98The+Righteous+Gemstones%E2%80%99+Season+2">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>
        <div class="td-post-content tagdiv-type">
            <!-- image --><div class="td-post-featured-image"><a href="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?fit=650%2C431&ssl=1" data-caption=""><img width="650" height="431" class="entry-thumb td-modal-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20431'%3E%3C/svg%3E" data-lazy-srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?w=650&ssl=1 650w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?resize=633%2C420&ssl=1 633w" data-lazy-sizes="(max-width: 650px) 100vw, 650px" alt="" title="The Righteous Gemstones" data-lazy-src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?resize=650%2C431&ssl=1"/><noscript><img width="650" height="431" class="entry-thumb td-modal-image" src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?resize=650%2C431&ssl=1" srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?w=650&ssl=1 650w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?resize=633%2C420&ssl=1 633w" sizes="(max-width: 650px) 100vw, 650px" alt="" title="The Righteous Gemstones"/></noscript></a></div>
            <!-- content --><p><strong>Everything We Know About &#8216;The Righteous Gemstones&#8217; Season 2</strong></p>
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="d67ab1c4da760787c45a4fee4587e952" data-index="3" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- asap link -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2968280150811945"
     data-ad-slot="3154853240"
     data-ad-format="link"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></center><center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- asas square -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2968280150811945"
     data-ad-slot="9111911020"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<p style="text-align: justify;">This series is a black comedy which includes so much drama and comedy about a reverent family and whose first season was super amazing for everybody.</p>
<p style="text-align: justify;">Also, this series sometimes follows criminal activities with so many adventures also, they shared a successes night with HBO on dark comedy which was ultimately a success for them because it was loved by the audience.</p>
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="d67ab1c4da760787c45a4fee4587e952" data-index="1" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- asas square -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2968280150811945"
     data-ad-slot="9111911020"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<p style="text-align: justify;">As we are aware of the news that HBO already renewed the second season and let us know more about this show.</p>
<h2 style="text-align: justify;"><strong><em>The Righteous Gemstones </em></strong><strong>Season 2 R</strong><strong>enewed </strong></h2>
<p style="text-align: justify;">As we all know that this series follows the storyline of the family which is Dysfunctional and the story of season one will be continuing in season two.</p>
<p style="text-align: justify;">As we are expecting the same cast to return in season two, if there are any changes then we will keep you updated on this because this is what we know so far.</p>
<p style="text-align: justify;">The creator of this show is Danny McBride and was directed by him, David Gordon Green, and Jody Hill. This story was written by Danny McBride, John Carcieri, Jeff Fradley, Grant Dekernion, Edi Patterson, Kevin Barnett, and Chris Pappas.</p>
<p style="text-align: justify;">The executive producers of this show are Danny McBride, Jody Hill, and David Gordon Green. The episodes are 30-60 minutes in all and the series was taken under Rough House Pictures.</p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://asapland.com/the-hbo-series-of-parasites-will-be-an-original-story-within-the-same-universe/75256/" target="_self" class="u276449689bd194499d5b21cc01d0168c"><!-- INLINE RELATED POSTS 1/1 //--><style> .u276449689bd194499d5b21cc01d0168c { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:#eaeaea; border:0!important; border-left:4px solid #34495E!important; box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -moz-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -o-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -webkit-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); text-decoration:none; } .u276449689bd194499d5b21cc01d0168c:active, .u276449689bd194499d5b21cc01d0168c:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .u276449689bd194499d5b21cc01d0168c { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .u276449689bd194499d5b21cc01d0168c .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .u276449689bd194499d5b21cc01d0168c .postTitle { color:#000000; text-decoration: underline!important; font-size: 16px; } .u276449689bd194499d5b21cc01d0168c:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">READ:</span>&nbsp; <span class="postTitle">The HBO series of Parasites will be an original story within the same universe</span></div></a></div><!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="d67ab1c4da760787c45a4fee4587e952" data-index="1" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- asas square -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2968280150811945"
     data-ad-slot="9111911020"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<h3 style="text-align: justify;"><strong>The Righteous Gemstones Season 2 Trailer:</strong></h3>
<p style="text-align: justify;">If you have not watched the first season yet, you can go binge-watch this show because you will gonna love this show. And if you have not watched the trailer of the second part here it is right below.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><div class="rll-youtube-player" data-src="https://www.youtube.com/embed/t383UpoLV5k" data-id="t383UpoLV5k" data-query="version=3&amp;rel=1&amp;showsearch=0&amp;showinfo=1&amp;iv_load_policy=1&amp;fs=1&amp;hl=en-US&amp;autohide=2&amp;wmode=transparent"></div><noscript><iframe class='youtube-player' width='696' height='392' src='https://www.youtube.com/embed/t383UpoLV5k?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent' allowfullscreen='true' style='border:0;' sandbox='allow-scripts allow-same-origin allow-popups allow-presentation'></iframe></noscript></span></p>
<h3 style="text-align: justify;"><strong>The Righteous Gemstones Season 2 Cast:</strong></h3>
<p style="text-align: justify;">Danny McBride as Jesse Gemstone, John Goodman as Dr. Eli Gemstone, Adam DeVine as Kelvin Gemstone, Edi Patterson as Judy Gemstone, Tony Cavalero as Keefe Chambers, Cassidy Freeman as Amber Gemstone, Skyler Gisondo as Gideon Gemstone, Walton Goggins as “Baby” Billy Freeman.</p>
<p style="text-align: justify;">Gregory Alan Williams as Martin Imari, Tim Baltz as Benjamin Jason “BJ” Barnes, Dermot Mulroney as Rev John Welsey Seasons, Jennifer Nettles as Aimee – Leigh Gemstone, Scott MacArthur as Scotty, Jody Hill as Levi, James DuMont as Chad, Troy Anthony Hogan as Matthew is the cast members of the season so far we know.</p>
<p style="text-align: justify;">Stay tuned for the next updates for release dates and when it is going to come on which platform because here we are always with the latest news and official updates that you want to know of any seasons.</p>

<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="d67ab1c4da760787c45a4fee4587e952" data-index="2" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- asap link -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2968280150811945"
     data-ad-slot="3154853240"
     data-ad-format="link"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div>        </div>

        <footer>
            <!-- post pagination -->            <!-- review -->
            <div class="td-post-source-tags">
                <!-- source via -->                <!-- tags -->            </div>

            <div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-padding td-post-sharing-style2 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fasapland.com%2Feverything-we-know-about-the-righteous-gemstones-season-2%2F76270%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Everything+We+Know+About+%E2%80%98The+Righteous+Gemstones%E2%80%99+Season+2&url=https%3A%2F%2Fasapland.com%2Feverything-we-know-about-the-righteous-gemstones-season-2%2F76270%2F&via=Asap+Land">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/&amp;media=https://asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg&description=Everything+We+Know+About+%E2%80%98The+Righteous+Gemstones%E2%80%99+Season+2">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Everything+We+Know+About+%E2%80%98The+Righteous+Gemstones%E2%80%99+Season+2 %0A%0A https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/&title=Everything+We+Know+About+%E2%80%98The+Righteous+Gemstones%E2%80%99+Season+2">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <!-- next prev --><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://asapland.com/mare-of-easttown-season-2-release-date-cast-plot-everything-we-know/76268/">Mare of Easttown Season 2 Release Date, Cast, Plot – Everything we know</a></div></div><div class="td-next-prev-separator"></div></div>            <!-- author box --><div class="author-box-wrap"><a href="https://asapland.com/author/maria/"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2096%2096'%3E%3C/svg%3E" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default" data-lazy-src="https://secure.gravatar.com/avatar/2ab502300203a26505fd95f7eb9d27c0?s=96&#038;d=mm&#038;r=g" /><noscript><img src="https://secure.gravatar.com/avatar/2ab502300203a26505fd95f7eb9d27c0?s=96&#038;d=mm&#038;r=g" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default" /></noscript></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://asapland.com/author/maria/">Maria Rivera</a></span></div><div class="td-author-description">Maria is the youngest team member of Asap Land. She joined as an intern as she was having a diploma in journalism. But, now as she gained experience, she is working as full-time editor and contributor on Asap Land. She loves to write news bulletins from the business world as she is quite fascinated with business.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div>            <!-- meta --><span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Maria Rivera"></span><meta itemprop="datePublished" content="2021-05-10T13:03:42-04:00"><meta itemprop="dateModified" content="2021-05-10T12:09:12-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://asapland.com/wp-content/uploads/2019/05/asapland.png"></span><meta itemprop="name" content="Asap Land"></span><meta itemprop="headline " content="Everything We Know About &#039;The Righteous Gemstones&#039; Season 2"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?fit=650%2C431&ssl=1"><meta itemprop="width" content="650"><meta itemprop="height" content="431"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts tdi_3_660 td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_3_660" ><script>var block_tdi_3_660 = new tdBlock();
block_tdi_3_660.id = "tdi_3_660";
block_tdi_3_660.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_3_660","td_column_number":3,"live_filter_cur_post_id":76270,"live_filter_cur_post_author":"4","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_3_660","tdc_css_class_style":"tdi_3_660_rand_style"}';
block_tdi_3_660.td_column_number = "3";
block_tdi_3_660.block_type = "td_block_related_posts";
block_tdi_3_660.post_count = "3";
block_tdi_3_660.found_posts = "2597";
block_tdi_3_660.header_color = "";
block_tdi_3_660.ajax_pagination_infinite_stop = "";
block_tdi_3_660.max_num_pages = "866";
tdBlocksArray.push(block_tdi_3_660);
</script><h4 class="td-related-title td-block-title"><a id="tdi_4_039" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_3_660" href="#">RELATED ARTICLES</a><a id="tdi_5_ca6" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_3_660" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_3_660 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://asapland.com/mare-of-easttown-season-2-release-date-cast-plot-everything-we-know/76268/" rel="bookmark" class="td-image-wrap " title="Mare of Easttown Season 2 Release Date, Cast, Plot – Everything we know" ><img width="218" height="150" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E"  data-lazy-srcset="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?resize=218%2C150&ssl=1 218w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?resize=100%2C70&ssl=1 100w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?zoom=2&resize=218%2C150 436w" data-lazy-sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Mare of Easttown Season 2 Release Date, Cast, Plot – Everything we know" data-lazy-src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?resize=218%2C150&ssl=1" /><noscript><img width="218" height="150" class="entry-thumb" src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?resize=218%2C150&ssl=1"  srcset="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?resize=218%2C150&ssl=1 218w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?resize=100%2C70&ssl=1 100w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?zoom=2&resize=218%2C150 436w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Mare of Easttown Season 2 Release Date, Cast, Plot – Everything we know" /></noscript></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://asapland.com/mare-of-easttown-season-2-release-date-cast-plot-everything-we-know/76268/" rel="bookmark" title="Mare of Easttown Season 2 Release Date, Cast, Plot – Everything we know">Mare of Easttown Season 2 Release Date, Cast, Plot – Everything we know</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://asapland.com/mr-inbetween-season-3-release-date-cast-plot-everything-we-know-so-far/76265/" rel="bookmark" class="td-image-wrap " title="Mr. Inbetween Season 3 Release Date, Cast, Plot – Everything We Know So Far" ><img width="218" height="150" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E"  data-lazy-srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=534%2C366&ssl=1 534w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?zoom=2&resize=218%2C150 436w" data-lazy-sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Mr. Inbetween Season 3 Release Date, Cast, Plot – Everything We Know So Far" data-lazy-src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=218%2C150&ssl=1" /><noscript><img width="218" height="150" class="entry-thumb" src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=218%2C150&ssl=1"  srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=534%2C366&ssl=1 534w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?zoom=2&resize=218%2C150 436w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Mr. Inbetween Season 3 Release Date, Cast, Plot – Everything We Know So Far" /></noscript></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://asapland.com/mr-inbetween-season-3-release-date-cast-plot-everything-we-know-so-far/76265/" rel="bookmark" title="Mr. Inbetween Season 3 Release Date, Cast, Plot – Everything We Know So Far">Mr. Inbetween Season 3 Release Date, Cast, Plot – Everything We Know So Far</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://asapland.com/ackley-bridge-season-4-release-date-cast-plot-and-everything-you-need-to-know/76257/" rel="bookmark" class="td-image-wrap " title="Ackley Bridge Season 4 Release Date, Cast, Plot And Everything You Need To Know" ><img width="218" height="150" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E"  data-lazy-srcset="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?resize=218%2C150&ssl=1 218w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?resize=100%2C70&ssl=1 100w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?zoom=2&resize=218%2C150 436w" data-lazy-sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Ackley Bridge Season 4 Release Date, Cast, Plot And Everything You Need To Know" data-lazy-src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?resize=218%2C150&ssl=1" /><noscript><img width="218" height="150" class="entry-thumb" src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?resize=218%2C150&ssl=1"  srcset="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?resize=218%2C150&ssl=1 218w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?resize=100%2C70&ssl=1 100w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?zoom=2&resize=218%2C150 436w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Ackley Bridge Season 4 Release Date, Cast, Plot And Everything You Need To Know" /></noscript></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://asapland.com/ackley-bridge-season-4-release-date-cast-plot-and-everything-you-need-to-know/76257/" rel="bookmark" title="Ackley Bridge Season 4 Release Date, Cast, Plot And Everything You Need To Know">Ackley Bridge Season 4 Release Date, Cast, Plot And Everything You Need To Know</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_3_660" data-td_block_id="tdi_3_660"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_3_660" data-td_block_id="tdi_3_660"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
        <div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/everything-we-know-about-the-righteous-gemstones-season-2/76270/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://asapland.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
				<div class="comment-form-input-wrap td-form-comment">
					<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
					<div class="td-warning-comment">Please enter your comment!</div>
				</div>
		        <div class="comment-form-input-wrap td-form-author">
			            <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-author">Please enter your name here</div>
			         </div>
<div class="comment-form-input-wrap td-form-email">
			            <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-email-error">You have entered an incorrect email address!</div>
			            <div class="td-warning-email">Please enter your email address here</div>
			         </div>
<div class="comment-form-input-wrap td-form-url">
			            <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
                     </div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='76270' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="13cd9de4dd" /></p><input type="hidden" id="ak_js" name="ak_js" value="93"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	    </div> <!-- /.content -->
                                </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside id="search-2" class="td_block_template_1 widget search-2 widget_search"><form method="get" class="td-search-form-widget" action="https://asapland.com/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside id="text-2" class="td_block_template_1 widget text-2 widget_text"><h4 class="block-title"><span>Get in Touch!</span></h4>			<div class="textwidget"><p>To get in touch with <strong>Asap Land</strong>, please write to <a href="/cdn-cgi/l/email-protection#eb8782988a8f9e998a859f8098cbabcb8c868a8287c5888486e1">lisadurantks @ gmail.com<br />
</a>. We will try our best to respond quickly. However, expect around 24 hours to get a response.</p>
</div>
		</aside><div class="td_block_wrap td_block_7 td_block_widget tdi_6_0f6 td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="tdi_6_0f6" ><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_6_0f6 = new tdBlock();
block_tdi_6_0f6.id = "tdi_6_0f6";
block_tdi_6_0f6.atts = '{"custom_title":"Related News","custom_url":"","block_template_id":"","header_color":"#","header_text_color":"#","accent_text_color":"#","m6_tl":"","limit":"8","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_6_0f6","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"tdi_6_0f6","tdc_css_class_style":"tdi_6_0f6_rand_style"}';
block_tdi_6_0f6.td_column_number = "1";
block_tdi_6_0f6.block_type = "td_block_7";
block_tdi_6_0f6.post_count = "8";
block_tdi_6_0f6.found_posts = "3651";
block_tdi_6_0f6.header_color = "#";
block_tdi_6_0f6.ajax_pagination_infinite_stop = "";
block_tdi_6_0f6.max_num_pages = "457";
tdBlocksArray.push(block_tdi_6_0f6);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">Related News</span></h4></div><div id=tdi_6_0f6 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/" rel="bookmark" class="td-image-wrap " title="Everything We Know About &#8216;The Righteous Gemstones&#8217; Season 2" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  data-lazy-srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?zoom=3&resize=100%2C70 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Everything We Know About &#8216;The Righteous Gemstones&#8217; Season 2" data-lazy-src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?resize=100%2C70&ssl=1" /><noscript><img width="100" height="70" class="entry-thumb" src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?resize=100%2C70&ssl=1"  srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/The-Righteous-Gemstones.jpg?zoom=3&resize=100%2C70 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Everything We Know About &#8216;The Righteous Gemstones&#8217; Season 2" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/everything-we-know-about-the-righteous-gemstones-season-2/76270/" rel="bookmark" title="Everything We Know About &#8216;The Righteous Gemstones&#8217; Season 2">Everything We Know About &#8216;The Righteous Gemstones&#8217; Season 2</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-05-10T13:03:42-04:00" >May 10, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/mare-of-easttown-season-2-release-date-cast-plot-everything-we-know/76268/" rel="bookmark" class="td-image-wrap " title="Mare of Easttown Season 2 Release Date, Cast, Plot – Everything we know" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  data-lazy-srcset="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?resize=218%2C150&ssl=1 218w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?resize=485%2C341&ssl=1 485w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?resize=100%2C70&ssl=1 100w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?zoom=3&resize=100%2C70 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Mare of Easttown Season 2 Release Date, Cast, Plot – Everything we know" data-lazy-src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?resize=100%2C70&ssl=1" /><noscript><img width="100" height="70" class="entry-thumb" src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?resize=100%2C70&ssl=1"  srcset="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?resize=218%2C150&ssl=1 218w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?resize=485%2C341&ssl=1 485w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?resize=100%2C70&ssl=1 100w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Mare-of-Easttown-Season-2.jpg?zoom=3&resize=100%2C70 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Mare of Easttown Season 2 Release Date, Cast, Plot – Everything we know" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/mare-of-easttown-season-2-release-date-cast-plot-everything-we-know/76268/" rel="bookmark" title="Mare of Easttown Season 2 Release Date, Cast, Plot – Everything we know">Mare of Easttown Season 2 Release Date, Cast, Plot – Everything...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-05-10T12:31:10-04:00" >May 10, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/mr-inbetween-season-3-release-date-cast-plot-everything-we-know-so-far/76265/" rel="bookmark" class="td-image-wrap " title="Mr. Inbetween Season 3 Release Date, Cast, Plot – Everything We Know So Far" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  data-lazy-srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=534%2C366&ssl=1 534w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?zoom=3&resize=100%2C70 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Mr. Inbetween Season 3 Release Date, Cast, Plot – Everything We Know So Far" data-lazy-src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=100%2C70&ssl=1" /><noscript><img width="100" height="70" class="entry-thumb" src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=100%2C70&ssl=1"  srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?resize=534%2C366&ssl=1 534w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Mr.-Inbetween-Season-3.jpg?zoom=3&resize=100%2C70 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Mr. Inbetween Season 3 Release Date, Cast, Plot – Everything We Know So Far" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/mr-inbetween-season-3-release-date-cast-plot-everything-we-know-so-far/76265/" rel="bookmark" title="Mr. Inbetween Season 3 Release Date, Cast, Plot – Everything We Know So Far">Mr. Inbetween Season 3 Release Date, Cast, Plot – Everything We...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-05-10T11:58:06-04:00" >May 10, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/ackley-bridge-season-4-release-date-cast-plot-and-everything-you-need-to-know/76257/" rel="bookmark" class="td-image-wrap " title="Ackley Bridge Season 4 Release Date, Cast, Plot And Everything You Need To Know" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  data-lazy-srcset="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?resize=218%2C150&ssl=1 218w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?resize=100%2C70&ssl=1 100w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?zoom=3&resize=100%2C70 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Ackley Bridge Season 4 Release Date, Cast, Plot And Everything You Need To Know" data-lazy-src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?resize=100%2C70&ssl=1" /><noscript><img width="100" height="70" class="entry-thumb" src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?resize=100%2C70&ssl=1"  srcset="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?resize=218%2C150&ssl=1 218w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?resize=100%2C70&ssl=1 100w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/Ackley-Bridge-Season-4.jpg?zoom=3&resize=100%2C70 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Ackley Bridge Season 4 Release Date, Cast, Plot And Everything You Need To Know" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/ackley-bridge-season-4-release-date-cast-plot-and-everything-you-need-to-know/76257/" rel="bookmark" title="Ackley Bridge Season 4 Release Date, Cast, Plot And Everything You Need To Know">Ackley Bridge Season 4 Release Date, Cast, Plot And Everything You...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-05-08T07:51:49-04:00" >May 8, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/the-stand-season-2-release-date-cast-plot-and-all-you-need-to-know/76250/" rel="bookmark" class="td-image-wrap " title="The Stand Season 2 Release Date, Cast, Plot And All You Need To Know" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  data-lazy-srcset="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/The-Stand-Season-2.jpg?resize=218%2C150&ssl=1 218w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/The-Stand-Season-2.jpg?resize=100%2C70&ssl=1 100w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/The-Stand-Season-2.jpg?zoom=3&resize=100%2C70 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px"  alt="" title="The Stand Season 2 Release Date, Cast, Plot And All You Need To Know" data-lazy-src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/The-Stand-Season-2.jpg?resize=100%2C70&ssl=1" /><noscript><img width="100" height="70" class="entry-thumb" src="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/The-Stand-Season-2.jpg?resize=100%2C70&ssl=1"  srcset="https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/The-Stand-Season-2.jpg?resize=218%2C150&ssl=1 218w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/The-Stand-Season-2.jpg?resize=100%2C70&ssl=1 100w, https://i0.wp.com/asapland.com/wp-content/uploads/2021/05/The-Stand-Season-2.jpg?zoom=3&resize=100%2C70 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="The Stand Season 2 Release Date, Cast, Plot And All You Need To Know" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/the-stand-season-2-release-date-cast-plot-and-all-you-need-to-know/76250/" rel="bookmark" title="The Stand Season 2 Release Date, Cast, Plot And All You Need To Know">The Stand Season 2 Release Date, Cast, Plot And All You...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-05-08T07:21:40-04:00" >May 8, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/master-of-none-season-3-release-date-announced-to-premiere-on-netflix-soon/76244/" rel="bookmark" class="td-image-wrap " title="Master Of None Season 3 Release Date Announced – To Premiere On Netflix Soon" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  data-lazy-srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Master-Of-None-Season-3.jpg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Master-Of-None-Season-3.jpg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Master-Of-None-Season-3.jpg?zoom=3&resize=100%2C70 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Master Of None Season 3 Release Date Announced – To Premiere On Netflix Soon" data-lazy-src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Master-Of-None-Season-3.jpg?resize=100%2C70&ssl=1" /><noscript><img width="100" height="70" class="entry-thumb" src="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Master-Of-None-Season-3.jpg?resize=100%2C70&ssl=1"  srcset="https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Master-Of-None-Season-3.jpg?resize=218%2C150&ssl=1 218w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Master-Of-None-Season-3.jpg?resize=100%2C70&ssl=1 100w, https://i1.wp.com/asapland.com/wp-content/uploads/2021/05/Master-Of-None-Season-3.jpg?zoom=3&resize=100%2C70 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Master Of None Season 3 Release Date Announced – To Premiere On Netflix Soon" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/master-of-none-season-3-release-date-announced-to-premiere-on-netflix-soon/76244/" rel="bookmark" title="Master Of None Season 3 Release Date Announced – To Premiere On Netflix Soon">Master Of None Season 3 Release Date Announced – To Premiere...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-05-07T12:46:51-04:00" >May 7, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/john-abrahams-satyamev-jayate-2-release-date-postponed-due-to-hike-in-covid-19-cases/76242/" rel="bookmark" class="td-image-wrap " title="John Abraham’s Satyamev Jayate 2 Release Date Postponed Due To Hike In COVID-19 Cases" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  data-lazy-srcset="https://i2.wp.com/asapland.com/wp-content/uploads/2021/05/Satyamev-Jayate-2.jpg?resize=218%2C150&ssl=1 218w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/05/Satyamev-Jayate-2.jpg?resize=100%2C70&ssl=1 100w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/05/Satyamev-Jayate-2.jpg?zoom=3&resize=100%2C70 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px"  alt="" title="John Abraham’s Satyamev Jayate 2 Release Date Postponed Due To Hike In COVID-19 Cases" data-lazy-src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/05/Satyamev-Jayate-2.jpg?resize=100%2C70&ssl=1" /><noscript><img width="100" height="70" class="entry-thumb" src="https://i2.wp.com/asapland.com/wp-content/uploads/2021/05/Satyamev-Jayate-2.jpg?resize=100%2C70&ssl=1"  srcset="https://i2.wp.com/asapland.com/wp-content/uploads/2021/05/Satyamev-Jayate-2.jpg?resize=218%2C150&ssl=1 218w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/05/Satyamev-Jayate-2.jpg?resize=100%2C70&ssl=1 100w, https://i2.wp.com/asapland.com/wp-content/uploads/2021/05/Satyamev-Jayate-2.jpg?zoom=3&resize=100%2C70 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="John Abraham’s Satyamev Jayate 2 Release Date Postponed Due To Hike In COVID-19 Cases" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/john-abrahams-satyamev-jayate-2-release-date-postponed-due-to-hike-in-covid-19-cases/76242/" rel="bookmark" title="John Abraham’s Satyamev Jayate 2 Release Date Postponed Due To Hike In COVID-19 Cases">John Abraham’s Satyamev Jayate 2 Release Date Postponed Due To Hike...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-05-07T12:10:40-04:00" >May 7, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://asapland.com/lucifer-season-6-release-date-and-when-is-6th-season-returning/76241/" rel="bookmark" class="td-image-wrap " title="Lucifer Season 6 Release Date and When Is 6th Season Returning?" ><img width="100" height="70" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E"  alt="" data-lazy-src="https://asapland.com/wp-content/plugins/td-standard-pack/Newspaper/assets/images/no-thumb/td_100x70.png" /><noscript><img width="100" height="70" class="entry-thumb" src="https://asapland.com/wp-content/plugins/td-standard-pack/Newspaper/assets/images/no-thumb/td_100x70.png"  alt="" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://asapland.com/lucifer-season-6-release-date-and-when-is-6th-season-returning/76241/" rel="bookmark" title="Lucifer Season 6 Release Date and When Is 6th Season Returning?">Lucifer Season 6 Release Date and When Is 6th Season Returning?</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-05-07T11:40:36-04:00" >May 7, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block --><aside id="top-posts-2" class="td_block_template_1 widget top-posts-2 widget_top-posts"><h4 class="block-title"><span>You May Like</span></h4><ul>				<li>
					<a href="https://asapland.com/rangde-ott-release-date-may-10th-everything-you-need-to-know/76124/" class="bump-view" data-bump-view="tp">RangDe OTT Release Date May 10th: Everything you need to know</a>					</li>
								<li>
					<a href="https://asapland.com/hazbin-hotel-episode-2-release-date/69175/" class="bump-view" data-bump-view="tp">Hazbin Hotel Episode 2: Release Date, Characters, and Everything You Should Know</a>					</li>
								<li>
					<a href="https://asapland.com/malayalam-films-nizhal-nayattu-on-the-simplysouth-ott-from-9th-may/76221/" class="bump-view" data-bump-view="tp">Malayalam films Nizhal &amp; Nayattu on the SimplySouth OTT from 9th May</a>					</li>
								<li>
					<a href="https://asapland.com/berserk-364-the-manga-still-paused-the-new-chapter-will-not-be-released-even-in-april/72031/" class="bump-view" data-bump-view="tp">Berserk 364: the manga still paused, the new chapter will not be released even in April</a>					</li>
								<li>
					<a href="https://asapland.com/tamilrockers/71024/" class="bump-view" data-bump-view="tp">TamilRockers: Download Hollywood Movies TamilRockers Tv Series Download</a>					</li>
								<li>
					<a href="https://asapland.com/narcos-season-all-episodes/71149/" class="bump-view" data-bump-view="tp">Index of Narcos (Season 1 to Season 3) Watch or Download All Episodes!</a>					</li>
								<li>
					<a href="https://asapland.com/master-of-none-season-3-release-date-announced-to-premiere-on-netflix-soon/76244/" class="bump-view" data-bump-view="tp">Master Of None Season 3 Release Date Announced – To Premiere On Netflix Soon</a>					</li>
								<li>
					<a href="https://asapland.com/one-piece-odens-flashback-is-about-to-end-the-fate-of-a-hero-in-the-next-episodes/72301/" class="bump-view" data-bump-view="tp">ONE PIECE: Oden&#039;s flashback is about to end, the fate of a hero in the next episodes</a>					</li>
								<li>
					<a href="https://asapland.com/tandav-season-2-release-date-cast/76051/" class="bump-view" data-bump-view="tp">Tandav Season 2 Release Date &amp; Cast</a>					</li>
								<li>
					<a href="https://asapland.com/fate-the-winx-saga-season-2-release-date/76027/" class="bump-view" data-bump-view="tp">Fate: The Winx Saga Season 2 Release Date, Cast, Plot - All We Know So Far</a>					</li>
				</ul></aside>                            </div>
                        </div>
                                    </div> <!-- /.td-pb-row -->
        </div> <!-- /.td-container -->
    </div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->

	
	
            <div class="tdc-footer-wrap ">

                <!-- Footer -->
				<div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-9 ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                            </div>

            <div class="td-pb-span4">
                            </div>

            <div class="td-pb-span4">
                            </div>

        </div>
    </div>
</div>
                <!-- Sub Footer -->
				    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-page-menu-container"><ul id="menu-page-menu" class="td-subfooter-menu"><li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-129"><a href="https://asapland.com/home/">Home</a></li>
<li id="menu-item-378" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-378"><a href="https://asapland.com/about/">About</a></li>
<li id="menu-item-369" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-369"><a href="https://asapland.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-370" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-370"><a href="https://asapland.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-372" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-372"><a href="https://asapland.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-2242" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-2242"><a href="https://asapland.com/team/">Team</a></li>
<li id="menu-item-2241" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-2241"><a href="https://asapland.com/contact/">Contact</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Copyright © 2019 Asap Land.                </div>
            </div>
        </div>
    </div>
            </div><!--close td-footer-wrap-->
			
</div><!--close td-outer-wrap-->




    <!--

        Theme: Newspaper by tagDiv.com 2019
        Version: 10.3.3 (rara)
        Deploy mode: deploy
        
        uid: 60996771d404b
    -->

    











<!-- JS generated by theme -->



<script src='https://stats.wp.com/e-202119.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.6.1',blog:'165120369',post:'76270',tz:'-4',srv:'asapland.com'} ]);
	_stq.push([ 'clickTrackerInit', '165120369', '76270' ]);
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://asapland.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
<script>"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><script src="https://asapland.com/wp-content/cache/min/1/5a295b3980909b87ea5e5e7855292956.js" data-minify="1" defer></script><noscript><link rel="stylesheet" href="https://asapland.com/wp-content/cache/min/1/5ee5c858f0a84d0dc41a5ba40c120fd1.css" media="all" data-minify="1" /><link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=10.3.3' type='text/css' media='all' /></noscript></body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1620666225 -->